Help - Desktop (Linux, Mac and Windows)

Showing results for 
Search instead for 
Do you mean 
Reply
Music Fan
sfairborne28
Posts: 1
Registered: ‎03-05-2012

Re: Remove from startup

I have tried the usual stuff and this boot at startup junk is not  for me.  

 

Pandora dosent force herself on me- why are you so clingy Spotify?  

 

Did you go through a bad breakup and cant stand being alone?

I just want to be with you on my terms... 

Music Lover
Scionfall
Posts: 1
Registered: ‎22-05-2012

Re: Remove from startup

Just had a user at work with this problem. I went into Edit | Preferences and selected "Do not open automatically" and also unchecked the "Spotify Web Helper" from MSConfig (Click Start, then type msconfig in the "Search Program Files... " box, Startup tab. Restarted the laptop and voila! No more Spotify on startup. 

 

Hope this helps anyone still having trouble.

 

Thanks,

 

Scionfall

Talent Scout
George
Posts: 273
Registered: ‎15-02-2012

Re: Remove from startup

Of course that also would mean that Spotify won't be able to open itself from a Web link (Play button etc) unless the client was already open... but I guess that's less annoying that the client opening when you don't want it to!

--
First was the record, then the cassette, the CD, then came along Spotify... that really did change everything!
Music Lover
Gbuffa
Posts: 2
Registered: ‎06-06-2012

Re: Remove from startup

I have also had this problem and have not been able to fix it in Prefs or through msconfig Startup. George can we get Spotify to make a patch or something? What's the deal? This is super annoying...

Music Lover
MajorNuts
Posts: 1
Registered: ‎10-07-2012

Re: Remove from startup

1. go to start and type: regedit

2. navigate to HKEY_current_user/Software/Microsoft/Windows/CurrentVersion/Run

3. delete spotity and spotify web helper

 

and that should solve your problem.

 

-MajorNuts

Music Fan
Hanky
Posts: 1
Registered: ‎25-07-2012

Re: Remove from startup

I checked all that on my computer but the final step to make it stop wasn't in that /run folder. I have everything checked. I have "don't automatically open on start up" checked and back when I did have the option on my start up files (which is now gone for some reason) I had it unchecked too. Spotify even tries to open 2 of itself when it starts up I will get the normal log in window plus some error window that says "another version of this is already open on your computer" or something to that effect. I love spotify and have been using it close to a year I believe but back when I had windows XP I never had these issues. Now that I've upgraded this is been the only application that causes the most annoyance for me on start up. Is there a fix for this? Or possibly an update soon? I've seen many people ask for help on this and get nothing that actually works. I know all the ways of opening msconfig, using CCleaner to do this as well but all of that is not even helping this issue. What's going on guys?
Music Lover
Gbuffa
Posts: 2
Registered: ‎06-06-2012

Re: Remove from startup

Yup - exact same for me Hanky. SUPER LAME!

Music Lover
ISanders
Posts: 1
Registered: ‎08-08-2012

Fix for Spotify startup

[ Edited ]

I had the same issue, spotify prefs, registry keys, msconfig, startup folder, and 3rd party boot utilities (ccleaner, glary utilities) would not work, or was not able locate the Spotify startup files. Here are the steps if all else seems to not work.

 

First open Spotify if it is not already running.

 

(1) Delete the Spotify Icon on your desktop if you currently have one. (Any Spotify shortcuts created before completing these steps will no longer work).

 

(2) Open task manager (ctrl + shift + esc)

 

(3) Switch to Processes tab and Right-Click "Spotify.exe" and select "open file location".

 

(4) In this folder you should see two application files named, "Spotify" and "SpotifyLauncher".

 Right click each file and add a 1 to the end of the file name.

"Spotify1" and "SpotifyLauncher1"

 

(5) Right click Spotify1 and select create shortcut. It should make a shortcut icon which you can drag to your desktop. (This file can be renamed to anything as long as the target is not changed).

 

Once this is complete, it should no longer load on startup. You can now use the created desktop shortcut to open Spotify.
Hope this helps - IS

 

 

Music Fan
Debs1
Posts: 1
Registered: ‎18-08-2012

Re: Fix for Spotify startup

WORKED PERFECT............ no more spotify on start up........... many thanks ;)

Music Lover
rgflan
Posts: 2
Registered: ‎19-04-2012

Re: Remove from startup

I've tried all the solutions in this thread and none of them have worked. I went into msconfig, registry editor, and spotify preferences. There aren't even any spotify options in msconfig or regedit, so I don't know what to do. If I don't find a solution soon I'm just going to have to uninstall on my computer. 

 

I haven't had this problem on my old windows vista laptop, but in my new windows 7 I have spotify pinned to the taskbar and it opens twice every single time I start up no matter what I do. I have to go in to the tast manager and stop the processes to close them. this is incredibly annoying and is making me a very frustrated spotify customer. 

Announcements
Happy Halloween


Want to be a Rock Star?
Read about our Rock Star Program.

Did you know?


More

Please bear in mind that the Community is not an official Spotify support service. It's a place where we all help each other, whether we work for Spotify or not. So please use your discretion when using the forum.