Cannot play Spotify on Echo Dot due explicit filter

Reply

Cannot play Spotify on Echo Dot due explicit filter

ppquintal
Casual Listener

I linked my Spotify account to my Amazon’s Echo Dot and everything was working OK, but from few days on, when I ask Alexa to play music from Spotify Alexa responsable “I cannot play music because the explicit filter is activated” which is not.

If I select Echo Dot from available devices, the explicit option is gray and I cannot turn it off.

If I ask Alexa to play music from Amazon Music, I don’t have issues.

 

7 Replies

Re: Cannot play Spotify on Echo Dot due explicit filter

Rock Star 6
Rock Star 6

Hey @ppquintal Welcome to the Spotify Community!

 

What i would recommend is checking whether your explicit content is enabled on your Alexa App. Sometimes it could turn on out of the blue.

 

Happy New Year!

Keanu_C

Keanu_CRock Star 6
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Cannot play Spotify on Echo Dot due explicit filter

ppquintal
Casual Listener
I’ve tried disabling the explicit filter in Alexa but I don’t have the option enabled. I also tried using the voice command but I doesn’t work.

Regards

Re: Cannot play Spotify on Echo Dot due explicit filter

Rock Star 6
Rock Star 6

Have you checked to see if the filter is active on Spotify? To check this you can go to Spotify App > Your Library > Go to Settings > Explicit Content > then Allow Explicit Content.

 

Keanu_C

Keanu_CRock Star 6
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Cannot play Spotify on Echo Dot due explicit filter

ppquintal
Casual Listener
I did everything like you say, but it didn’t work. What Amazon told me is that I cannot use Spotify in my Echo Dot because my IP address is from Mexico and in this moment this feature is not available for Mexico customers.

I was shocked.

Re: Cannot play Spotify on Echo Dot due explicit filter

Rock Star 6
Rock Star 6

Right... Well sorry i couldnt help you out, but its great to know this information.

 

Happy New Year!
Keanu_C

Keanu_CRock Star 6
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Cannot play Spotify on Echo Dot due explicit filter

Yngkush420
Music Fan

This could be an Amazon issue go to your Alexa app and check your search settings the two could be conflicting with each other meaning Spotify is allowing explicit content but Alexa is not I hope this helps you and best of luck

Highlighted

Re: Cannot play Spotify on Echo Dot due explicit filter

RM77
Casual Listener

I have the same problem.  II hav a feeling it's an Amazon issue as well.  I'm in Canada and we do not have the explicit filter option available to us either. Somehow it believe it became active on my Amazon account and I have no way to turn it off or disable it. I have now spent over an hour on 2 occasions with Amazon support who cannot figure it out. I mean, can they not go into my account and see if I have it turned on and turn it off?  They are now blaming Spotify.

 

I even attempted to switch my country to the US to see if the options became available to try and disable it but I need a US credit card to do so. Very frustrating. I'm going to add some additional music services to see if it blocks those too. Best of luck.

SUGGESTED POSTS