Help Wizard

Step 1


Change the language of the communication emails

Change the language of the communication emails

I currently get the communication emails in Spanish, I am in the UK so it should be English as default.  I can't find anywhere that I can change it from Spanish to English - I've looked at previous topics but there no longer appears to be an option to change my preferred language.

3 Replies

Hi there @Nikki_S,

thanks for reaching out to the community !


Please open your account page and check the language presented on it.

You can change the language at the bottom right corner of the page by clicking on the country flag displayed. 


A second option is to check the language settings of all app versions you've been using - both on mobile and desktop. 


Waiting on your update 🙂

Thanks for reply - I've checked those.  


The country is set as GB and the country is UK. Everything on the account is in English except the communication email.

Hi @Nikki_S,

thanks for your patience !


I would suggest you try playing music from a UK-based network like 3G or 4G, and then to reinstall the Spotify app.


Let me know how it goes 🙂

Suggested posts