Announcements

Create an account

Create an account

mdubois90

I've invited my daughter to a family account. She has her own email, but can't create an account. She enters the info, but when she hits the "open account" button, it just spools. I've tried it on several computers and with Edge and Chrome. Also tried it on my phone in Safari. It won't create an account. Any ideas?

Reply
3 Replies

Jack

Hey @mdubois90, help's here!

 

Hmm. You say you've tried multiple devices with different browsers, which is good to know. Have you tried any of those browsers on an incognito window?


We'd also suggest restarting the WiFi router, just in case.

 

When you say it 'spools', do you mean it's stuck on a loading screen? You don't see any error messages at all? If you do, send us a screenshot and we'll take a look.

 

It might be possible that the email she's trying to use might already have an account linked to it. It might be worth reaching out to us directly via email, or by tweeting our support handle, if none of the above steps help out.

 

Keep us posted! We hope to have your daughter rocking an account soon.

mdubois90

No, none of those ideas worked. I was able to get her signed up on the family account finally but the instructions and site functions work really poorly for family sign-up. Was very disappointed to pay for family plan and not get any help with the sign-up until after I fixed it myself. 

mdubois90
None of those things worked. It seems the family plan has glitches for adding family members.

Suggested posts

Env: prod