Announcements

Help Wizard

Step 1

NEXT STEP

Glitch: random people can takeover your Roku device via Spotify

Solved!

Glitch: random people can takeover your Roku device via Spotify

Programming glitch, request to Spotify and Roku to fix:

Any person who is on the same wifi network can assume control of a Roku device with spotify on it. Even if the owner of the Roku device is using it to watch Netflix, or connected as a computer monitor to their laptop, or any other use at all, if another person joins the same wifi they can see the Spotify/Roku device, assume control of it by streaming their Spotify account to it - even if the owner of the Roku has their own Spotify account on it. Currently I am in a building that uses a large shared wifi for about 200 residents. Any one of us who has Roku with Spotify on it can play music on each others' devices any time we want at any volume. In the past month I've had my TV taken over 3 times at volume of 75 or more, some stranger decided to stream their Spotify to my Roku TV while I was in the middle of watching Netflix or using the TV as an external monitor while doing work on my laptop. There is no way to stop this, it is how it is programmed which is quite evidently not good programming. To Spotify & Roku: Please allow users to select an 'allowed' list of devices which can access Spotify on Roku. Allowing *anyone* to randomly stream their Spotify to any Roku device on the same wifi is quite horrible. I am aware that users have been bringing this request to you for years as I have seen the forums; there are many tech blogs/forums out there with confused and angry people as their Roku device keeps getting hijacked, and many of the posts are years old with many users in the follow up comments saying they have experienced the same problem. So it's been years and you have not addressed this extremely bad programming issue. Urgently I request to you, give users a menu option to select 'permitted devices'. This should be addressed right away.

Reply

Accepted Solutions
Marked as solution

The easiest way to do this is in your Roku settings. You just have to switch it to permissive meaning you have to give permission for other devices, apps, etc., to connect. Here's a video from Cord Cutters which is a world renown company for helping with all things digital: 

 

https://youtu.be/41a284e-5wg

View solution in original post

3 Replies
Marked as solution

The easiest way to do this is in your Roku settings. You just have to switch it to permissive meaning you have to give permission for other devices, apps, etc., to connect. Here's a video from Cord Cutters which is a world renown company for helping with all things digital: 

 

https://youtu.be/41a284e-5wg

This is not a working solutions cus i have that option disabled and users still able to connect to my roku device

Hey there @Xihnchao

 

Thanks for reaching out here, and welcome 🙂

 

We understand where you're coming from. However, this behavior seems to be related to some specific Roku settings. 

 

In this case, we'd suggest reaching out directly to the folks at Roku so they can take a deeper look into this and continue with the help. 

 

If anything else comes up, the Community will be here.

 

Take care!

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts