Announcements

Google home pauses on linked Spotify premium account

Solved!

Google home pauses on linked Spotify premium account

LiamKenn

Plan

Premium

Country

Ireland

 

Device

Google Home

Operating System

 

Hi,


I have Google Home linked to my Spotify premium

account and after about 10 seconds Google Home stops playing the song. 

 

Also If casting form Spotify iPhone app Spotify cycles  through 10 or more songs without playing before starting to play a random song. 

Issue does not happen with other music providers on Google Home.

 

Hope you can help.

Thanks,

Liam



 

Reply

Accepted Solutions
Marked as solution

Katerina

Hey there @LiamKenn,

 

Welcome to the Community and thanks for getting in touch!

 

Just to confirm, have you tried performing a clean reinstall of the app with these steps

 

It's also worth trying to unlink your Spotify account from your Google Home app and then relinking it again to see if that makes a difference.

 

Another thing you can try is to take a look at this page to see some other steps that could help out in this case.

 

If the issue persists, feel free to let us know if you experience this on other devices and other networks as well, and we'll see what we can suggest.

 

Keep us posted on how it goes!

KaterinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself! 

View solution in original post

Marked as solution

LiamKenn

Hi,

 

Issue resolve. 

Posting here in the even that it happens to someone else. 

I had to reset Google Home twice and the issue was resolved. 

This was not a Spotify issue even though the Spotify music service appeared to be the only one impacted. 

Again, thanks for the help. 

Liam

View solution in original post

25 Replies
Marked as solution

Katerina

Hey there @LiamKenn,

 

Welcome to the Community and thanks for getting in touch!

 

Just to confirm, have you tried performing a clean reinstall of the app with these steps

 

It's also worth trying to unlink your Spotify account from your Google Home app and then relinking it again to see if that makes a difference.

 

Another thing you can try is to take a look at this page to see some other steps that could help out in this case.

 

If the issue persists, feel free to let us know if you experience this on other devices and other networks as well, and we'll see what we can suggest.

 

Keep us posted on how it goes!

KaterinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself! 

LiamKenn

Hi,

 

Thank you for your help and apologies for the delayed reply. 

Unfortunately, the suggestions did not work and I’m left with the same issue.

 

In order to isolate the issue I ensured all devices iPhones etc were off and I operated Google home with the linked Spotify account as a stand alone device. 

The issue still persists. 

Any further help would be appreciated. 

In advance, thanks. 
Liam

 

Marked as solution

LiamKenn

Hi,

 

Issue resolve. 

Posting here in the even that it happens to someone else. 

I had to reset Google Home twice and the issue was resolved. 

This was not a Spotify issue even though the Spotify music service appeared to be the only one impacted. 

Again, thanks for the help. 

Liam

Katerina

Hey there @LiamKenn,

 

Thanks for keeping us in the loop on this.

 

Glad to hear that you resolved the issue after resetting your Google Home device. In this case, we hope you don't mind us marking your post as a solution so users can find this info more easily.

 

Don't hesitate to give us a shout if there's anything else we can help with - we're happy to lend a hand.

 

Have a lovely day 🙂

KaterinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself! 

hey I am also having the same issue .

it also takes very long to cast.

dthai
This actually isn't a solution as the problem re-appears over and over. So it is unfortunate that the moderator would actually mark this as a solution, when it is in fact not. This is a bug either from the side of Spotify or Google - either way it should be rectified on Spotify/Google side, not the user side. If you did any research mod, you would have realized that this a problem that has occurred for many other users. I will be cancelling my account in the next few days for another service that has better integration with Google Home.

Fardad66
I have the exact same problem with no solution

Ver

Hey folks,

 

Thanks for reaching out to us 🙂

 

We'd suggest you give these steps a go and run a clean reinstall. This one is more thorough than the usual one.

 

In case you're using any battery optimization or power saving apps, you can deactivate them for Spotify. 

 

It's also a good idea to try with another connection. Are there any changes?

 

Keep us in the loop! If you have questions, you know where to find us.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

bq7h47ktw3h6ax3

I have the same issue: after skipping 5 songs, song number 6 is played for 10 seconds, then the music stops. Funny enough this is only when playing music: podcasts work just fine. This also only happens when playing on speaker groups (setup in Google Home). Playing just one speaker is fine, a speaker-pair is also fine. I already did a clean reinstall of both Google Home and Spotify and rebooted all my speakers.

CarlosE

Hi there @bq7h47ktw3h6ax3,

 

Thanks for reaching out and welcome to the Community.

 

Just to confirm, did you already try unlinking and linking again your Spotify and Google Home accounts? You can find the steps to do so here.

 

Additionally, we understand that you already rebooted your speakers, but could you do it again a couple of times in a row? This can help refresh the syncing and may be useful for such issues.

 

Keep us posted on how it goes.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

bq7h47ktw3h6ax3

Hi! Thanks for the reply. I did unlink and link my Spotify account already. I rebooted all speakers twice today, waiting for a minute in between. This to no avail I'm afraid. This only started recently, I've had this system for about two years...

Jeremy

Hi there @bq7h47ktw3h6ax3,

 

Thank you for your reply and confirmation.

 

Can you let us know if it occurs while connected to one specific device or multiple devices?


We'll keep an eye ut for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

bq7h47ktw3h6ax3
It only occurs when casting to a speaker group. Any single device, or any speaker pair is fine. The weirdest thing is that podcast are casting fine to a speaker group…

Jeremy

Hi again @bq7h47ktw3h6ax3,

 

Thank you for your confirmation.

 

Can you let us know how you start the playback? for example, from the app (mobile or desktop) or voice command etc..

 

Also- do you have the app open when the music stops?

 

Keep us posted 🙂

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

bq7h47ktw3h6ax3
I've tried casting through the Spotify app, casting through the Google Home
app and using voice commands, it all yields the same result.

I had not tried to close the app within the 10 seconds of play time, I just
tried it out but it has the same result.



Thanks!

MafeG

Hey @bq7h47ktw3h6ax3,

 

Thank you for your swift reply!

 

Would you mind creating a hotspot on your phone and connecting all your devices to check if that makes any difference?

 

Also, can you log in to your Spotify with another account, such as a friend's or a family member's to see if the issue persists?

 

We'll be on the lookout.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

bq7h47ktw3h6ax3

Hi, do you mean that I have to go to each of my devices, forget the wifi network, setup a hotspot then use a different device to connect to the hotspot and setup my devices to use the hotspot network? Are you sure hotspot allows for this?

Alex

Hey @bq7h47ktw3h6ax3,

 

Thanks for the reply.

 

You just need to activate the hotspot network from your phone. After that connect the other Home devices to that network. This way you can test if the issue persists on another network. If that's the case you can have  a look at the router settings to see what may be causing this issue.

 

We need to go through these troubleshooting steps to see what can be causing this issue.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

bq7h47ktw3h6ax3

Hi! Sorry for the late reply, I had some difficulties with setting up all devices under my hotspot. I therefor decided to delete all speakers, all speaker groups, reset all speakers to manufactures settings and setup everything again. This solved my issue! To be clear, I did not setup my speakers on my hotspot. I'm so glad! Thanks for the help!

Suggested posts

Env: prod