Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

I can't hide "recently listened artists"

I can't hide "recently listened artists"

Hello

I would like to hide my recently listened to artists. Unfortunatly, disabling the setting/option doesn't update my profile and restarting the app re-enable the option back. Is there a solution ?

 

I'm running Windows 10 with a premium spotify account.

Reply
10 Replies

Hey @user-removed, welcome to the Spotify Community!

 

Just to confirm, are you trying to hide the Recently Played section under Your Library, or do you want to hide the songs you play with your account from other users when you go to Settings > Toggle off the option Publish my activity on Spotify?

 

Also let us know the exact model of your device and the Spotify version it runs.

 

Keep us posted.

JulianModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

No i'm trying to hide from other my "Recently Played Artists" when they click on my spotify profile, the same place where they can see my playlists and my following. I use a desktop with the latest windows 10 update and the latest spotify version (i think), the "1.0.83.318.g6c07039d". But what is the difference between "Show my current Top Artsists" and publish my activity on Spotify", will this one hide my playlist as well, which i don't really want to ?

 

 

Thanks for the clarification @user-removed.

 

The Publish my activity on Spotify option won't affect they playlist showed in your profile. 

 

Also, when you look at your profile from your own account, you will see your Recently Played Artists. However, with the Show my current Top Artsists option off, they won't show up for other users when they take a look at your account.

 

Let us know if that helps.

JulianModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Thanks a lot

But I still have the problem of the option "Show my current Top Artists" re enabling back itself whenever i restart the app, but also not updating my profile (even from someone else perspective) immediatly after i toggle of the option. Is there any way to force that ? Because with any other option so as "Close button should minimize the Spotify windows to the tray" it works just find after the restart 😕

Have you tried on another device?

When i wasn't sure if the Recently payed artists show only for me or not, I tried to see with another account which happened to be on another device. I did try on my phone to turn it off but the option isn't there. I also uninstall the phone app in case there were any conflicts between the 2 devices. But i will try disabling the option with another account.

Hey @user-removed.

 

Thanks for getting back to us.

 

Could you send us your Spotify app version numbers? Also, if you turn off this setting on a different device, does it affect your account?

 

Keep us in the loop.



“Music acts like a magic key, to which the most tightly closed heart opens.”
― Maria Augusta von Trapp

Hello

if the number of the desktop is not this one, i don't know how to find it. My only other device is my phone but unfortunately i can't access the 2 options that i am looking for on mobile, they are just not there.

 

Thank you for your time

No worries!

 

You can find the Spotify version under Help > About Spotify, on desktop.

 

In the meantime, try running Spotify as the administrator to see if the setting turns back off. To do this, just right-click the Spotify icon, and click the "Run as administrator" option.

 

Let us know how it goes.



“Music acts like a magic key, to which the most tightly closed heart opens.”
― Maria Augusta von Trapp

So my Spotify version is 1.0.83.318.g6c07039d

 

Running Spotify as an administrator doesn't seem to have any effect. The option always toggle back on itself after a restart, whether or not the app was ran as an admistrator before and after i changed the option. By the way, i just tried on another laptop, and it did the same thing as my main device 😕

Suggested posts