Help Wizard

Step 1

NEXT STEP

My name suddenly became random number

Solved!

My name suddenly became random number

Plan

Premium

Country

 France

My Question or Issue

 

I don't know why but my name became a string of random characters everywhere, in my Spotify on my PC, on my phone too, in all my playlists. How do I make my name come back. Because I will soon publish songs and I have playlists I created that have followers, I can't stay like this. 
The first time I connected to Spotify it was with my facebook account, and it's still the way I'm connecting to it.

If anyone knows how to solve this issue thanks in advance !

Reply

Accepted Solutions
Marked as solution

Hey @jack_arnd.

 

Could you login on the website and go to Privacy Settings? Check if you have opted out of Spotify processing your Facebook data. When you opt out there, it keeps your account usable but it will stop using a lot of data, for example your name. You can read here what information exactly.


If this didn't help, log in on your Facebook profile and make sure that you have granted Spotify access to your personal information.

 

Should do the trick. Let us know if you have further questions.

 

Have a nice day!

View solution in original post

3 Replies

Try to disconnect/ unlink your Facebook-Account and if it's even then still a weird looking number, try to change your name and in the worst case you have to call the spotify support. 

Marked as solution

Hey @jack_arnd.

 

Could you login on the website and go to Privacy Settings? Check if you have opted out of Spotify processing your Facebook data. When you opt out there, it keeps your account usable but it will stop using a lot of data, for example your name. You can read here what information exactly.


If this didn't help, log in on your Facebook profile and make sure that you have granted Spotify access to your personal information.

 

Should do the trick. Let us know if you have further questions.

 

Have a nice day!

Hello Guido !

Thank you for your answer ! It didn't solve the issue right away so I gave it a few days but that worked ! Thank you very much !

Regards.

Suggested posts