Spotify and Echo dot

Solved!
Reply

Re: Spotify and Echo dot

TanniaFx
Newbie

I am from Indonesia. I have linked my Spotify, but when I say "Alexa, play the music in the spotify", Alexa answer "resuming Spotify". When I looked to my Laptop, the Spotify already started, but Alexa was still silent. How to fix it?

Re: Spotify and Echo dot

Engku
Casual Listener
I think its your internet connection. My Spotify works fine all the time,
except when the internet line goes off.

Re: Spotify and Echo dot

ushermocha
Casual Listener

My mistake. This earlier comment solved my problem. My country was set incorrectly in the Amazon app:

 

gangeleri wrote:

To solve it, log into your amazon account then go to your account —> Content and devices —> Settings Tab. Once there modify your country setting to USA.




Re: Spotify and Echo dot

Mateooo
Newbie

Hi guys,

 

I am from Czech Republic and bought echo dot in Germany Amozon. I cannot conect to spotify at all even when I changed location to US. Can someone help me please??

 

Re: Spotify and Echo dot

Bartman236
Newbie

I have the same problem. Set all links to US, even my default shipping address, but it makes no difference at all. Spotify is nowhere to be found. The previously mentioned 'solutions' are bogus.

Re: Spotify and Echo dot

doublesharp
Newbie

I couldn't find the Spotify skill either and my country has always been the USA. It ended up being that Spotify is not a skill - from the Alexa app select the menu icon then "Music, Video, & Books" and select Spotify to connect. Hope that helps! 

Re: Spotify and Echo dot

Christian81
Newbie

I live in germany and both my Amazon Account and Spotify premium are set for germany - i can’t select Spotify to connect, only Amazon Music and tunein

Highlighted
Solution!

Re: Spotify and Echo dot

digisprint
Casual Listener

There is a lot of confusion for non-American users apparantly. I lve in Belgium and looked for 2 full days for a solution. But I found it. You have to change the address in your Amazon account (.co, or .co.uk or whatever Amazon shop you use) BUT NOT YOUR DELIVERY ADRRES. Read on: in the long list of options under your account, choose "Your Content and Devices", Choose the "Settings" TAB (3rd) and there change the address to any Address in US or Germany. Keep your delivery address of course to your home address.
In the Alexa App or alexa.amazon.com, now you will immediately see Spotify under Music & Books appear. Also Keep the location of your Alexa in this App on your home address. It needs this for your local weather forecast. Thank you Amazon for confusing me totaly....

View solution in original post

Re: Spotify and Echo dot

jeroenmaes
Newbie

This worked great for me! (also Belgium, but apparentely living in the UK now ;) ) Any idea whether, when changing the setting back to my home country after configuration, the spotify option in the alexa app will disappear or break again? Seems a bit risky with Brexit around the corner, no?

Re: Spotify and Echo dot

digisprint
Casual Listener
LOL! No I think it is more about countries where Amazon has a shop
SUGGESTED POSTS