The credit card boxes on the subscription screen don't load.

Solved!
Reply

The credit card boxes on the subscription screen don't load.

DDCommander
Newbie

For some reason I just get the spinning circle loading icon on the page, even on multiple computers. Is there any way around this? The only other post I could find on this problem said to enter CC info on your profile, but I can't find any option to do so. Help!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: The credit card boxes on the subscription screen don't load.

Lollman
Newbie

I had this issue when trying to upgrade using Chrome. The issue was my Norton toolbar and safety search extension. I disabled them and the loading or refresh symbol stopped and the credit card info boxes appeared. Hope this helps, but if you or others still have this issue, after disabling extensions, I found Microsoft Edge worked too.

 

Take care,

View solution in original post

2 Replies

Re: The credit card boxes on the subscription screen don't load.

Jason
Spotify Legend

Hey @DDCommander

 

Thanks for your post.

 

This does seem an odd one. Have you tried adding the details via an alternate web browser, device, or an incognito window? We'd also recommend clearing the internet browsing history. How does that help?

 

If you could also provide us a screenshot, that would be super helpful.

 

Thanks.

Highlighted
Solution!

Re: The credit card boxes on the subscription screen don't load.

Lollman
Newbie

I had this issue when trying to upgrade using Chrome. The issue was my Norton toolbar and safety search extension. I disabled them and the loading or refresh symbol stopped and the credit card info boxes appeared. Hope this helps, but if you or others still have this issue, after disabling extensions, I found Microsoft Edge worked too.

 

Take care,

View solution in original post

SUGGESTED POSTS