Android Auto - Liked songs under Artist Tab won't play

Android Auto - Liked songs under Artist Tab won't play

DPL1

Plan

Premium

Country

USA

Device

Galaxy S10

 

My Question or Issue. 

  1. I select  liked songs under the artist tab in Android Auto and instead of playing the liked songs for that specific artist, it plays the last liked song I added to my library. 
Reply
19 Replies

Mihail

Hey @DPL1,

Thanks for reaching out on the Community!

Did this start happening after a specific event, such as update to your phone/head unit or the Spotify app. We'd also appreciate some screenshots or a recording of what you see at your end when you try to play the liked songs by a specific artist. 

Keep us posted. We'll be on the lookout for your reply.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

DPL1
This started happening after the latest update to the Spotify app.

Eni

Hey there @DPL1

 

Thanks for your reply.

 

Could you try with a different phone to see if the issue persists across devices?

 

On another note, we'd like to know if this happens too when you try to do the same directly on your phone. 

 

Keep us posted.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

MDN84

Greetings. I'm also experiencing this issue. It only occurs while using Android Auto and not the Spotify app.

Scenario 1

  1. Go to Your Library
  2. Click Artists
  3. Select an Artist
  4. Click Liked Songs
  5. Spotify will start playing from the general Liked Songs folder, not the Artist's Liked Songs

Scenario 2

  1. Clear all music from the general Liked Songs folder
  2. Go to Your Library
  3. Click Artists
  4. Select an Artist
  5. Click Liked Songs
  6. All music stops playing, the screen does not refresh from the last song played and a square Stop button is displayed with a moving circle around it.

This is difficult to capture with screenshots but I did my best.

Spotify 1.png
Spotify 2.png

Jeremy

Hi @MDN84,

 

Thank you for your reply and explanation.

 

Can you let us know your Spotify version of the Android auto device?

 

Also do you notice a difference when they restart the system?

 

We'll keep an eye out for your reply 🙂

Take care!

 

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

MDN84

Hi Jeremy,

Spotify version is 8.6.70.1102

Android Auto is 6.9.613724-release

I restarted my phone (Motorola Razr) several times but that did not resolve the issue.

 

Eni

Hey @MDN84

 

Thanks for sending us this info. 

 

Could you try connecting your phone to your car's stereo using a different type of connection to see if this behavior persists?

 

If possible, also try using Android Auto with a different phone to see if the same happens. This way we can check if it's rather related to the phone.

 

Keep us posted on how it goes.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

MDN84

Eni,

I connected the phone to my car and the issue was present in my vehicle as well (see attached photo). So, just to clarify, the issue has presented itself in the following situations:

  • Android Auto for Phone Screens app (Motorola Razr)
  • Android Auto in-car application (Motorola Razr connected to 2021 Mazda MX-5)

I also asked a friend to duplicate the scenario identified in the previous post. He's experiencing the same issue I identified. He said "I can confirm it plays random liked songs. It's not doing what it's supposed to do."

IMG_20211017_172330867.jpg

DPL1
Yes. Exactly what's happening to me. It started happening after an update a few weeks ago. The problem still persist even after a few updates.

MafeG

Hi @DPL1,

 

Thank you for your reply.

 

We'd like to get this passed on to the right team to have it investigated. In order to do that, please share with us a video showing how the issue develops.

 

Just attach the video to your next response to us by using the Insert Video option in the post editor.

 

This will be extremely helpful as due to the COVID pandemic, our access to Android Auto testing environments is limited.

 

Keep us posted!

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

MDN84

All,

 

I was able to record some videos of the issue. Just to reiterate, this occurs while using the Android Auto for Phone Screens app and Android Auto connected to my vehicle.

 

DPL1: Hopefully I'm not hijacking your thread but I think we're experiencing the same problem and I figure the more samples they have, the better.

 

Matt

DPL1
Yes. Thanks for posting video

MafeG

Hi folks, 

 

Thank you for sharing that information!

 

We went ahead and reported it with the right folks who will look into this backstage. At the moment we're not able to provide you with a timeframe for a fix, but we can recommend keeping the app updated. Also, keep an eye on this thread in case we have news.

 

@DPL1 Please share with us the make, model and OS of your phone, as well as the Spotify version of the Android auto device. This way we can pass it on as well. 

 

We'll be on the lookout.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

DPL1

Samsung Galaxy S10

G973USQS6GUJ1

Spotify version - 8.6.72.1121

Android Auto - 6.9.613724

MafeG

Hi @DPL1,

 

Thank you for sharing this info.

 

We've gone ahead and passed it on to the team who is looking into this.

 

@MDN84 Could you confirm if you're running the latest app version? The current one is the 8.6.72.1121

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

MDN84

Confirmed.

8.6.72.1121

DPL1
As of this morning (for me) problem has been resolved. I hope this issue has been resolved for others, as well. Thanks Spotify team and others who posted on this thread.

MDN84

Resolved on my end as well. Thanks to everyone involved for your help!

 

Eni

Hey there @MDN84 and @DPL1

 

Fantastic news! Give us a shout if it starts misbehaving again; we're always here to help. 

 

Have a good one 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Suggested posts