Google Assistant Play Soundtrack in Wrong Language

Reply
Highlighted

Google Assistant Play Soundtrack in Wrong Language

Casual Listener

Plan

Premium

Country

USA

Device

Pixel 3

Operating System

Android

 

My Question or Issue

I use Google Assistant frequently to play music on Spotify. There are a bunch of very popular soundtracks that try to listen to but it ends up playing a version from another country. It's consistent in the version it chooses but seems to pick different countries. For example when I ask it to play the Frozen 2 soundtrack, it always plays the Netherlands version. When I ask it to play the Coco soundtrack, it always plays the Portuguese version. 

 

I think this is a Google Assistant problem, not a Spotify one but am not sure. Any ideas?

 

 

5 Replies
Highlighted

Re: Google Assistant Play Soundtrack in Wrong Language

Visitor

Same issue for me. Not ideal when the kids keep asking google to play Frozen II and get it in another language. Didn't have an issue when asking Alexa to play it though, so I agree it's a google assistant problem.

Highlighted

Re: Google Assistant Play Soundtrack in Wrong Language

Casual Listener

When command to Alexa has some problem.

Highlighted

Re: Google Assistant Play Soundtrack in Wrong Language

Newbie

The Tangled soundtrack plays the French version. This just started last month and seems to be isolated to Disney soundtracks but I haven’t tried many others. 

Highlighted

Re: Google Assistant Play Soundtrack in Wrong Language

Casual Listener
Super annoying. All was fine for 2 years but then out of nowhere... frozen in Spanish, frozen 2 in Italian and Moana in Japanese. Work around is to make a playlist of the English version and google will prioritize it.
Highlighted

Re: Google Assistant Play Soundtrack in Wrong Language

Moderator
Moderator

Hey folks,

 

Thanks for reaching out and posting in the Community!

 

We know that it's an often overlooked step, but advise you to log out and back in two times in a row in your Spotify app. It's also a good idea to restart your device. These steps are very effective, but often overlooked.

 

If that doesn't solve things, we recommend that you check which languages are added to your Google Assistant. It can help to leave only the language you want to hear the tracks in activated. You can learn how to do this here. Be sure to restart your device after you modify these settings.

 

Hope you find this useful. Keep us posted how you get on.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards
SUGGESTED POSTS