Announcements

It doesn't show on the lock screen anymore

Solved!
Reply

It doesn't show on the lock screen anymore

Casual Listener
Spotify doesn't show on the lock screen anymore, unless it's already at the notification bar before I block my cellphone. It used to show up on the lock screen even if I blocked it directly from the app. Is it an error?
2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Re: It doesn't show on the lock screen anymore

Newbie
Goto settings>sound and notification>scroll down until you see keep notifications on lockscreen. This use to be in the security section of lollipop just enable it and it should work

View solution in original post

Solution!

Re: It doesn't show on the lock screen anymore

Newbie

Logging out and back in worked for me too. Was driving me crazy!

View solution in original post

48 Replies

Re: It doesn't show on the lock screen anymore

user-removed
Not applicable

Re: It doesn't show on the lock screen anymore

Casual Listener
It doesn't work for me, my cellphone is a Motorola, although it's running Android Marshmallow

Re: It doesn't show on the lock screen anymore

user-removed
Not applicable

Can you test out a 3rd party Lock Screen app like Dodol which is 100% free, I've seen this issue before and only 3rd party Lock Screen app managed to partially fix it.

Re: It doesn't show on the lock screen anymore

Casual Listener
Thank you, but it didn't work as well.

Re: It doesn't show on the lock screen anymore

user-removed
Not applicable

Let's try this one.

 

Settings > Sounds & Notifications > Notification > While Locked > Hide Sensitive Content (Leave all Spotify notifications disabled).

 

In addition to the above you must allow notifications on the lock screen through the security settings.

Settings > Lockscreen & Security > Notifications

 

Also you can give a Musixmatch a try (Requires internet connection while used).

 

https://play.google.com/store/apps/details?id=com.musixmatch.android.lyrify&hl=en_GB

Re: It doesn't show on the lock screen anymore

Music Fan

As far as I can remember, the Spotify app doesn't show a notification if it's on screen, so if you lock the screen with it on screen you will not get the controls in the lockscreen.
Keep in mind that the way music controls work in Android changed in Lollipop. Before the controls were a universal widget that was identical for every app. In Lollipop and Marshmallow, you just get your notification shade in the lockscreen, so the music controls are actually the same notification panel the app generates normally. So, before Lollipop you would get the controls even if Spotify was on screen when you locked the phone since the widget was not tied to the notifications shade.

Re: It doesn't show on the lock screen anymore

Community Legend

That's not so on my phone @ParanoidARG. SGS7 Edge with android 6.0.1 and I get the spotify notification in all cases. Marshmallow gives us a lot of control over app behaviour which might confuse. My settings:

 

Lock sreen & security/Notifications on lock screen =  Show content

 

Notifications/advanced:

  • Allow notification = on
  • Previews in pop ups = on
  • Hide on lock screen = off
  • Hide content on lock screen = off

Re: It doesn't show on the lock screen anymore

Regular

It's not perfect but it works for me (Android 6):

1. Go to Settings>Lock Screen>Switch off: Skip the slide page.

2. Go to Settings>Sound and notification>Click on: When device is locked>Select Show all notification content.

3. If you want to hide sensitive content in your apps for your lock screen then: Go to Settings>Sound and notification>Click on: App notifications>then select the app you want to hide content>Switch on Hide sensitive content. Do this or each app you want.

Hope it helps!

 

Solution!

Re: It doesn't show on the lock screen anymore

Newbie
Goto settings>sound and notification>scroll down until you see keep notifications on lockscreen. This use to be in the security section of lollipop just enable it and it should work

View solution in original post

SUGGESTED POSTS