Help Wizard

Step 1


Music Cast Yamaha and spotify connect

Music Cast Yamaha and spotify connect

I've seen previous posts about this problem but never any clear answers.

Yesterday everything worked fine but today my spotify won't connect to any of my two Yamaha speakers (yas-306 and Wx-010) using Spotify connect.

They both show up, but after 10 seconds of trying to connect it just stops trying. (normallly gets connected within 3 seconds)

I've tried everything (firmware, reconnect, re-install, network, etc, etc) which was mentiod in previous posts.

Is this a (temporary) Spotify problem, as suggested on serveral forums or is this something different?

All other functions work perfectly on both speakers, only Spotify won't work. 

5 Replies

I have to same problem. I can use the musiccast app without problems to power on/off my wx-030 devices and start a radio, but I cannot connect to them to spotify connect. I can start spotify on my rx-v681 however

I have the same problem with two Wx-010 using Spotify connect with premium account. I bought the speakers one week ago and they never worked.

I have the same problem. Unfortunately the link you posted is not reachable anymore.
I can connect using airplay to the speaker but Spotify doesn’t work reliably. Sometimes only after removing power and plugging it in again.

Just recently got a new (cable)modem/router from my internet provider and sofar (almost) everything works perfectly again. Exept for being a totally different router it also has uPnP capability, which my previous one didn't have.

Perhaps that could be the trick?


It almost works perfectly exept for the fact that Spotify sometimes suddenly pauses the playlist after an hour or so. Strange thing!

Here I also think the problem is caused by the internet modem/router. I was getting more and more network problems. My problems seem to be solved since a few days after I did following things:

- I have rebooted our internet modem + completely shut down my musiccast devices (plug out the power cable)

- I disabled my pi-hole dns server


I am not 100% sure what was causing it, but it only got solved after the reboot of the modem + plugging out the power cable of the musiccast devices, so i don't think the pi-hole has anything to do with it.


for information: my internet provider (and thus provider of the router): belgium/telenet

Suggested posts