Help Wizard

Step 1


My Echo only showing in Spotify when I say “Spotify Connect”

My Echo only showing in Spotify when I say “Spotify Connect”

Hello we have five Amazon Echos (various versions) and all show available in my Spotify devices menu except our new Echo Dot kids edition. When I go to cast music I can cast to any Echo in our house except our new Echo dot kids. 

However when I say “Alexa Spotify connect” the Echo dot pops up on my Spotify devices menu instantly and music can be played on it from my phone. But any time after that the Echo Dot kids goes away from the devices menu. 


How can I get this Echo to always remain an option in Spotify devices menu?

I’m using an iPhone 13. Brand new Amazon Echo kids edition. Sportily Premium. 

1 Reply

Hi there @austinmsteele,


Thanks for reaching out here and welcome to the Community!


If you’re having trouble seeing a device in the picker, we’d recommend going through the following steps:

  • Perform a quick reinstall and restart both devices
  • Make sure the Spotify version and device firmware are up to date
  • Make sure both devices are on the same WiFi network
  • Try restarting your router ,to see if that makes a difference
  • If possible, try if it works on a different Spotify account
  • Check if your devices are set in the right region
  • Make sure ‘Show local devices only’ is toggled OFF (try switching it on and off again)

If all of the above checks out but your Alexa speaker still isn't showing up, you may want to check out the steps at Amazon's help center or get in touch with their support team for further assistance.


Note that since the Echo Kids is quite new, there might be a setting or part of its firmware making it undiscoverable when it's not active, in which case there isn't much we can do.


Hope this helps. Let us know how you get on.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts