Native spotify source in Kenwood DMX7705S - "Disconnected"

Reply
Highlighted

Native spotify source in Kenwood DMX7705S - "Disconnected"

Choncie
Regular

Plan

Premium

Country

USA

Device

Samsung Galaxy 9

Operating System

Android

 

My Question or Issue

 This Kenwood DMX7705S unit supports Bluetooth as source as well as (theoretically) Spotify & Pandora as native sources.

 

I can select BT as source and spotify plays songs, displays song info on the unit - but there is no album art, and no spotify-specific controls (like, add, playlists, etc).

If I select Spotify as source, it says "Disconnected" over the screen even though BT is still connected. If I press play from the phone on the app then it actually plays spotify with spotify as source on the unit, but it still says 'disconnected', no song info displays, and all controls are greyed out.

If I connect by USB and use android auto, spotify does work within the android auto interface (shows art, song info).

Have tried changing many little settings etc, no joy. I have given spotify all permissions and enabled 'broadcast' option in spotify settings in the app. Have also updated the Kenwood unit to the latest firmware posted on their site.

Long & short of it is, I would like to use the native controls with spotify as source on this unit since that's really why I bought the stupid thing... :|

I will point out that Pandora as native source works fine (art & song info & native controls all work).... Up your game spotify...

If anyone has any suggestions, please offer 'em up. Losing hope here...

25 Replies

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

Sirjamesthe3
Newbie

Having the same issue.. following.

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

Mikko82
Casual Listener

Hi,

 

I have exactly same issue with my DMX-7017BTS unit. Spotify app in the unit keeps saying "disconnect" even though I can play through bluetooth or android auto via usb just fine.

 

This started few weeks ago, until that it worked fine. Nothing seems to work, even tried other android phones beside my Nokia 7 plus, but same thing. Just "disconnect" showing in the spotify app in the unit.

 

Updated my firmware on the kenwood unit, updated phone apps, resetted everything and installed again, nothing works.

 

If anyone finds a solution, please let me know. Thanks

 

- Mikko

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

napoleonryanite
Newbie

Same issue. Worked fine untill about a month ago, then suddenly stopped. Pandora works fine, regular blutooth works fine as well. I even got a new phone, thinking that was the issue. Still not working.

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

Haloperidol
Newbie

Same issue. Dnx8170dabs and s8.

Runs good several weeks ago. 

Location Germany

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

goralkin
Casual Listener

 


Same problem with my DDX595. Worked perfectly with my 2 Android phones until week ago. Nothing helps!! Is any solution for it??

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

Mikko82
Casual Listener

Hello again,

 

So I contacted Spotify support and exchanged detailed information of the problem with them including screenshots etc. Hopefully there is a solution coming soon.

 

In the meantime im using older version of spotify 8.4.78.530 from november which I have no problems at all. You can download earlier versions from apkmirror.com 

 

- Mikko

 

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

goralkin
Casual Listener

Mikko, you are awesome!!

It worked for me. working fine!

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

Choncie
Regular

@Mikko, @ goralkin - can you confirm you are on Kenwood DMX7705S & galaxy S9 (versus other kenwood/android products)?

 

I just tried this older apk and see exactly the same behavior as before, unfortunately...

Re: Native spotify source in Kenwood DMX7705S - "Disconnected"

goralkin
Casual Listener

Hi. My head unit is DDX595, using both Galaxy s9 & S7 Phones. it is the App issue.

Lately my phone updated automaticly the version to the latest one and the connection gone again. I just reinstalled it to older Mikko's version and it working again.

The latest version turning the bluetooth options in the phone to the "call audio" only and turns the "media audio" to off, That's why there is no connection between the devices.

SUGGESTED POSTS