Announcements

No audio over Bluetooth in car - song "plays" but no sound?

Solved!

No audio over Bluetooth in car - song "plays" but no sound?

or3n

Hi everyone,

 

I just installed Spotify (the new version with the UI overhaul) on my HTC Droid Incredible 2 Android smartphone (running 2.3.4). The app works great with headphones, but when I tried using the app in my car with my phone paired to the car's audio system via Bluetooth, when a song is "playing," no audio plays through the car speakers (or through the phone speakers either for that matter). That is, it seems to think that the sound is playing through the car, but it actually is not.  The issue isn't with my phone itself because other music apps work just fine with the car speakers (Winamp, Pandora, HTC's music app). 

 

Has anyone else had this issue or know what's going on? Spotify devs, is this a known issue for which there might be a fix in the works?

 

Thanks so much!

 

Oren

Reply

Accepted Solutions
Marked as solution

Jemi

Hey there, help's arrived. 

 

Try the following and see if it works after each step:

Keep in mind that some car models require Spotify Premium for it to work. You'll find more info about how you can play your music in the car here.

 

Hope that helps!

View solution in original post

61 Replies

JeJaPail

We're on the same boat. Sometimes I can listen to my music from my Samsung Galaxy S2 (Android) through my Mini Boombox loudspeaker using bluetooth. And sometimes there is no sound at all through my Mini Boombox even though the bluetooth is on. Really irritating.

 

I hope there is someone in here that is abble to help us solve this problem.

 

Regards

drjakata

I have a similar issue, but I can't get the newer version of Spotify to play through my headphones, phone speaker or bluetooth since the auto-upgrade to the latest version a week or so ago.  The song looks like it is playing, just no sound!

It worked great, no issues at all until the upgrade.

 

I tried an uninstall/reinstall - no luck

 

I hope someone chimes in as well.

mminasian

I have experienced this exact problem.  It is specifically prevalent if your device autoconnects to a different bluetooth device and you try to change to a different one.  

 

I have found 2 solutions:

1. Restart

2. Force close and re-open app

 

To all of the people out there who claim that losing the "Exit" option in the app isn't a big deal, THIS is exactly why it is.

BucsFan40

I have had the same issue with Bluetooth but mine is with a headset. The 2 solutions mminasian posted which were:

 

I have found 2 solutions:

1. Restart

2. Force close and re-open app

 

seem to temporarily fix the issue.

 

 

 

 

 

Phone; Samsung SCH-R720

Provider: MetroPCS

OS: Android 2.3.4

Bluetooth Headset: Plantronics Voyager Pro+

 

jeromem75

same here. I have to try that solution to make it work.

Liam
I think this is a known issue, and one that (I hope, for the users sake) is being worked on.

soccergirl

I'm having same issue. Little different though: I can click a song to play it, the next song on the playlist does what you're talking about, I have to click skip back and skip forward to get it to play, and it does it just playing from phone speakers as well

danxcook

Same issue here. Even if you disconnect from BT the audio is still mute. The play time ticks away but no audio. All other apps fine.  Force close and reopen fixes. 

 

This especially happens since the new radio feature was added. 

 

PLEASE FIX IT!

Wade-0

This is the exact issue that brought me here to this forum.  What I have observed with the latest version is this:

 

Playback over Bluetooth or Aux (headphone) begins just fine for the first few songs.  Eventually it will "look" like it is playing, but there is no audio.  Hitting Pause, waiting a couple seconds, then hitting Play will cause the song to start over from the beginning with audio output again.  The audio drops out once the next song starts playing though.  This gets really annoying, since I have to do it for every song once it starts this behaviour.

 

It does this with the screen on or off too.  However, I was able to successfully stream for about an hour (until I lost service in the mountains) by starting playback, and then returning to the home screen and using the Widget to control Spotify. So apparently the issue is related to having Spotify as the foreground app.  Scratch that theory, it started doing it again today while I was testing it with the Widget.  Haven't figured out any kind of pattern to reproduce. Sometimes it works great, but most of the time it doesn't.

personanongrata

you just never know what new whacky behavior you're going to get with this app.  BT is my 90% use case, as i listen in the car mostly.  about 50/50 that it will play after making the connection -- half the time i have to force kill the app and restart it.  on disconnection, anything might happen -- it might start playing randomly several minutes later, it might crash the app, it might not play anything again until i force close it, just to name a few.

 

spotify has stated more than once that BT is not "officially supported" - -getting anyone's attention about this just ain't gonna happen -- even though every other reputable music player for android handles BT, and even transmits track info.  i would imagine on the priority list, this is way way way below landscape mode (which we've been waiting for for over 4 months), and GBs per month of rogue data usage...

Chrester

Just getting started with this in my car. I have a Belkin audiocast handsfree and it was no problem to getting it work just fine.

However it sometimes don't start to play music when I get into my car and turn the key.

It seems as is I change playlist or choose another song it start to work.

But its a bit annoying to have to pull out the phone (desire hd) and manually do that everytime the problem occurs 😞

Hope to see some improvement here pls 🙂



Cheers!

Samsung Galaxy SII

Chrester

"spotify has stated more than once that BT is not "officially supported" is this true?

If so then I wont keep using spotify anymore. I want to use it in my car and if bluetooth is a no go then im not interested anymore.

I will go back to TuneIn radio or something instead.



Cheers!

Samsung Galaxy SII

personanongrata

@Chrester wrote:

"spotify has stated more than once that BT is not "officially supported" is this true?

If so then I wont keep using spotify anymore. I want to use it in my car and if bluetooth is a no go then im not interested anymore.

I will go back to TuneIn radio or something instead.


yes it is true.  if you search the forum, you should be able to find more than one post where a customer rep states this.  i remember it distinctly, because of how absurd it was that the old app actually had a link to android BT settings (which apparently wasn't "supported")...

Chrester

Then we will have to wait for that they will support BT in the future I guess. No renew of my membership until then.



Cheers!

Samsung Galaxy SII

personanongrata

don't hold your breath. 🙂

jpalo

Having this same issue, it has worked just perfect until the last two months. Ever second song (or so), the audio disapperas, while the song is playing just fine. Putting Spotify to Offline mode and back has fixed the issue, but bit clumsy as you need to keep doing it all the time. Using Android 4.2 on Galaxy Nexus. Issue was also on Android 4.1.2.

 

Good time to give Xbox Music Pass a try as soon as the Android app is released. Sorry Spotify, not "supporting" mobile devices and Bluetooth is your loss. I've heard these "mobile devices" are pretty popular nowadays.

PhireX

Yep, bluetooth audio seems patchy.. once it's working, it's fine.

 

I reconnect my head unit to my phone, and it's fine. I think spotify doesn't realise it's paired and should be outputting to bluetooth, and I bet if I plugged headphones in I could hear it playing (but lets face it, why, when I can bluetooth it into my $2,500 alpine system...)

ehong_naper

After emailing with Spotify Technical support, they suggested that I do the following steps:

 

http://www.spotify.com/uk/help/faq/tech/clean-reinstallation-of-spotify/

 

And here is what I did:

 

1. Clear Spotify Data.

2. Uninstalled Spotify App.

3. Reboot (My battery is sealed on my HTC Evo 4G LTE, i.e. HTC One X equivalent).

4. Reinstalled Spotify from Google Play.

 

After I did those and re-login into the Spotify app, after a few songs I encountered infamous "No Internet Connection" error.   Other Internet apps are still working (Browser...)   So I turned off the WiFi and then turned it on again.  That fixed it.   So the Spotify's handling the WiFi error seemed to be a problem in the start.

 

After that, I started streaming radio and things looked a lot better.   Now it doesn't seem to encounter the radio with no sound and internet error errors anymore.   I also tried another device (HP Touchpad with CM9) and that looked ok as well.   I'll continue to observe how things go but so far it seemed to be ok now.

sorencito
I have just switched from Simfy. Now I found out that I can't listen to music in my car with Spotify. Great...

Suggested posts

Env: prod