Announcements

No internet connection on first startup

No internet connection on first startup

Patrick124

Plan

Premium

Country

Netherlands

Device

Samsung Galaxy S7

Operating System

8.0.0

 

My Question or Issue

When opening the app, it's extremely sluggish. Home, library and settings won't load. A message pops up: 'no internet connection' (or the Dutch translation of the message). Closing the app, then opening again solves the problem. When the app isn't opened for a while (about an hour), the problem resets. The problem has been there for a few months now, and I thought it'd be fixed by now. I've tried several things, like going into offline mode, trying different networks (WiFi or 4G), re-installing the app (several times) and more. No results, and the problem is consistent and reliable. 

 

Edit: I just received an update for the Spotify app. I will see if the issue is resolved. If I don't add to this message, consider this problem solved.

 

Edit: after a few days, the issue took another form. I thought it to be solved but it isn't yet. See below.

 

Reply
16 Replies

MafeG

Hi @Patrick124,

 

Thank you for posting on the Community.

 

Let's give it a try with the latest update and see how it works. 

 

If it doesn't do the trick, please perform a clean reinstall of the app. We understand you already reinstalled it, but these steps are more thorough and can be helpful to get rid of any cache that might be causing trouble. 

 

Keep us posted!

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Patrick124

As of now, the problem seems to be fixed through the update. Funny coincidence, that a problem I faced for several months, is solved right after I started a topic about it. Maybe I should start more topics 😉

MafeG

Hey @Patrick124,

 

It's great to know that everything is working fine now 🙂

 

Remember to always keep your app updated, so you don't miss any fixes or new features. Don't hesitate to give us a shout if you have more questions.

 

Have a nice day!

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

rpb272

This was exactly my problem.   Will be interested to see if the latest update fixes it.

Jeremy

Hi there @rpb272,

 

Thank you for your reply.

 

You can follow the steps that's provided in this article to make sure that your app always is up to date.

 

Let us know how everything goes 🙂

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

rpb272

Unfortunately this problem is still present despite a clean reinstall and the latest update.

 

After Spotify has not been used for a while "No internet connection is available" displays for about 30 seconds before the first song plays.  This is despite my phone being on good wifi.

 

@Patrick124 - is your problem fixed?

Alex

Hey @rpb272,

 

Thanks for the reply.

 

Can you let us know if you get the error if you're using mobile data too?

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Patrick124

@rpb272 Yes, the update fixed it for me. My phone is a Samsung S7 with Android 8.0.0. Maybe you have a phone/Android version that hasn't been fixed?

rpb272

Hi Alex

The problem seems to happen when my phone is connected to WiFi

If I turn WiFi off and rely on 4G the problem seems to go away.  Not sure why that should happen?

MafeG

Hi folks,

 

Thank you for keeping us in the loop.

 

@Patrick124 We're glad to hear the update did it for you. Remember to always keep your app updated so you don't miss any fixed or new features. 

 

@rpb272 Please reset your modem/router to see if the issue persists. If it does, could you try connecting to a different WiFi network and see how the app works? 

 

Lastly, please let us know the brand and model of your phone, and the Android version you're running.

 

Keep us posted!

 

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Patrick124

The issue has taken a slightly different form. The message now comes up consistently and correct, only when there's no internet connection. But often, when it appears, the app becomes really sluggish, although I think that doesn't have anything to do with the message anymore, but just how Spotify works offline.

 

 

 

MafeG

Hi @Patrick124,

 

Thank you for your reply. 

 

If the app doesn't detect any internet connection it will display that message. To avoid it, please make sure to activate the Offline Mode whenever you're going to use the app without internet. 

 

However, it's not normal for the app to run so slowly. In case you're using an SD card please try removing it and see how it works that way. 

 

Keep us posted!

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Patrick124
Thanks for your reply! I will try that, as I am using an SD card. But it can be a while before I know whether it works or not.

rpb272

The problem still persists.

 

On WiFi if Spotify has not been used for a while there is a delay before songs play - often 20 seconds or more.

 

On 4G songs play straightaway.    

 

I am using a Pixel 5 with Android 11.   I have downloaded all liked songs.

maglax

I've also been having this issue for the past few weeks. Last night it progressed to most playlists not loading the song list. The ones that will load and play, will stop after a few songs.

 

Upon opening the app, it takes less than 10s to load the home screen. If I select a playlist it will load indefinitely. I've tested to at least 1m (my screen timeout). If the playlist loads, it will play. After a few songs, the player will stop in the middle of song. When I open the app, no song is listed as playing. If I try to open the playlist, it will load indefinitely. I've mostly been trying to open playlists from spotify, so not massive.

 

I've tried logging out and back in, clearing cache, uninstalling and reinstalling, rebooting. None have fixed the issue.

 

This is occurring on 4G and wifi. No other apps (youtube used as test) were having issues on either 4G and wifi.

 

Win 10 desktop player has no noticeable issues.

 

Plan: Premium

Phone: LG V30

Android Ver: 9

Carrier: T Mobile

Spotify App ver: 8.6.54.820

MafeG

Hi folks,

 

Thank you for keeping us in the loop.

 

@rpb272 Please let us know if you were able to test the app using a different WIFI connection, this way we can rule out an issue related directly with the network.

 

@maglax We understand you already reinstalled the app, please run a clean reinstall as this one is more thorough than a regular one.

 

Also, if you're using an SD card try removing it and testing the app again. 

 

We'll be on the lookout. 

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod