Announcements

Offline mode on Samsung Galaxy Watch Active 2

Reply
Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Visitor

I'm also having this problem. I've seem posts on this dating back to 2017, and still, 3 years later, spotify devs can't seem to fix this. It's simply unacceptable. With the amount of money these people must be making, I just can't fathom how this is still a problem in LATE 2020. The app has a 2 star review on the Galaxy store. It's just ridiculous. 

Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Casual Listener

Same problem here. Just as OP and mbking23 wrote, it works once but as soon as I reconnect my phone i get the same error message again.

Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Casual Listener

The only solution I've found is to turn the watch's wifi off all the time.  Issue still occurs after a week or so, but much better than every time.  Having to keep wifi off is pretty lame though.

Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Newbie
Same here! 😕 please, Spotify Team, help us with this issue!
Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Casual Listener

The ONLY solution there seem to be is to download individual tracks (save to your liked songs" and access them through "my collection" on the watch. No problems with this so far, but granted I've only tried it for about a week.

Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Moderator
Moderator

Hey folks,

 

Thanks for searching for the answer you need here! 

 

Since a reinstall temporarily solves this issue, it seems that something is interfering with the apps cache. We suggest that you check that the Galaxy Wearable and Spotify apps have all necessary permissions enabled and are excluded from battery optimization. You can do this by following these steps: 

  1. Mobile Settings> Apps> Spotify/ Galaxy Wearable> Permissions. Allow everything you see there.
  2. Mobile settings> Apps> Spotify/ Galaxy Wearable> Battery> Optimize battery usage> select top All (not optimized for apps)> Spotify/Galaxy Wearable> disable.

It's a good idea to also make sure that both are also excluded from any cache clearing apps. Keep in mind that even if you didn't download any such apps, some devices have them preinstalled. 

 

Hope you find this useful. Let us know how you get on.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards
Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Casual Listener

Thanks for the advice, I'll give it a shot. 

 

One thing that I've found interesting is that if I completely turn off wifi on my galaxy active 2 and only use bluetooth, the issue seems to disappear (or at least occurs way less frequently).  So I guess I'm not completely convinced that it is cache related since my watch can still sync with my phone, but only over bluetooth.

Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Regular
I have the same problem with an Active 2. The app has ALWAYS prefered streaming over offline. Even though the tracks are saved on the watch, it streams the music if it has the possibility being connected to either WiFi, LTE or Bluetooth. You noticed this as everytime the watch lost WiFi or BT-connection, the music paused for a couple of seconds before the app realized that the music is also available offline and continued to play.

Now on the latest update of the app it just forgets about having the music stored offline altogether. The app just says "Unable to play. Please check your connection"
Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Moderator
Moderator

Hey there @Defeat,

 

Thank you for your post.

 

Could you confirm if you followed the steps above that were provided by @Mihail?

 

Once we know how that went we can see what we can suggest you try next 🙂
 

Cheers!

PeterModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
Highlighted

Re: Offline mode on Samsung Galaxy Watch Active 2

Regular

Hi, thanks for the reply! Both wearable and spotify app on the phone has all the permissions @Mihail

 

And you don't have to reinstall the whole app, it's enough to just delete data and cache in the apps settings and then download your songs again and it works for a while (until the app goes into sleep mode and forgets about your downloaded songs?)

 

I've noticed that if you put the app in offline mode right after you've downloaded your songs it works just fine to play them the day after. Actually I've had the app online over the day now and it works fine now!

 

SO EVERYBODY, TRY TO TURN ON OFFLINE MODE RIGHT AFTER YOU'VE DOWNLOADED YOUR SONGS AND THEN GO ONLINE AGAIN AFTER A DAY AND SEE IF IT WORKS! 🙂

 

 

SUGGESTED POSTS