Queue inaccessible, button greyed out


Queue inaccessible, button greyed out

Casual Listener






Samsung Galaxy J3

Operating System

Android 9

Spotify Version


My Question or Issue

I cannot access my queue. The button is in the bottom right but it is greyed out. When I click it nothing happens. 


I habd already done a clean reinstall by clearing my data and then uninstalling and reinstalling, but this did not fix the problem. Although to be honest, I don't think the "clear data" worked properly because when I reinstalled, my library and downloads were still intact. Also, doing a clean reinstall is not a good solution; users should not have to delete their libraries just to fix a glitch. 


Please suggest something else. I would like to be able to get the service I'm paying for. Thank you.

2 Replies

Re: Queue inaccessible, button greyed out

Rising Star 1 eltoch
Rising Star 1

Hey! Sorry to hear you're having issues!


Performing a clean reinstallation shouldn't delete your library, that is saved in your account rather than in the app data, so you should be safe there! 


Here's a great list of Spotify Troubleshooting tips that you might want to try that are specific to Android, small glitches like what you mentioned can sometimes be fixed this way. 


Let me know if this works for you! If not, I'll see what else I can suggest to fix it :)


Thanks for reading! If this worked for you, please mark this as the solution, this way others will be able to find the answers to their problems in the future! :)

Re: Queue inaccessible, button greyed out

Casual Listener

When I first posted about this, none of the solutions you suggested were successful. Then about two weeks later, after I had stopped using Spotify for a while, I logged back in, and the queue button was once again accessible. Great!


However, just now, the queue button is once again greyed out and inaccessible. I have been using Spotify regularly in the last few weeks, including using the queue (it was working fine just yesterday) but now once again I am having the same problem. The queue button is greyed out and inaccessible. I can still add things to the queue, but I cannot access it in any way.


Can you please provide me with a solution, and if possible an explanation as to why this keeps happening? I have already tried a clean reinstall, as well as the rest of your suggestions from early October. They have not solved the problem.


Thank you.