Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Sony Xperia 1 not downloading songs

Sony Xperia 1 not downloading songs








Sony Xperia 1


Operating System

Android version 9


My Question or Issue

I have just upgraded my phone to Sony Xperia 1, installed Spotify, but am unable to download any songs. Click on download for album or playlist and just sits there saying waiting for download. Have tried uninstalling and reinstalling the app, cleared data and cache, factory reset, checked storage permissions but still get the same issue. Any ideas would be appreciated.

3 Replies

Hey @elessarmeneldur 


You should try using a different network (WiFi) to see if it's not a connectivity issue.


Hope it helps. 🙂

osorniosSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hey @elessarmeneldur,

Thanks for reaching out!

Just like @osornios said - it's a great idea to try downloading over another connection.

If this doesn't do the trick, follow the steps in this post in the exact same order as given there and let us know what happens.

We're here for you 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Hi There,


I laso have the Xperia 1 and have had alot of issues with Spotify, first the app would regularly crash shortly after playing anything, that seems to be OK now. 


I have tried this with multiple WiFi networks and the music downloads, shortly afterwards it appears as ready for download again, meaning that the green marks are grey again. I haven't switched back the download toggle either. 


This is very annoying considering I have had nothing but problems with the Spotify recently and now I cannot listen without using my data.




I chatted with support and followed their instructions, but that hasn't brought about any changes

Suggested posts