Spotify app on android won't play, show cover art or download

Reply

Spotify app on android won't play, show cover art or download

ellegaarddk
Casual Listener

I use this old Android device as a player for the kitchen. But recently it stopped downloading songs. It could play already downloaded songs, but not stream. It had good connection and can play through webplayer alright.

 

I've tried uninstalling and clearing cache - it got rid of all the downloaded stuff, so now I have nothing to play. Didn't fix the problem though.

 

No SDcard, but 5GB free on device.

 

Plan

Premium

Country

Denmarl 

Device

Teclast tablet X10 3G

Operating System

 

Android 5.1 

 

4 Replies

Re: Spotify app on android won't play, show cover art or download

Moderator
Moderator

Hey @ellegaarddk.

 

Thanks for getting in touch!

 

Let's try something else. Could you head over here and click on REMOVE ALL DEVICES? You'll need to re-download across all devices however.

 

Then, reinstall the app again and see if that solves the issue.

 

We hope it does! Let us know if it doesn't or if you have further questions.

 

Have a nice day.

GuidoModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Re: Spotify app on android won't play, show cover art or download

ellegaarddk
Casual Listener

Sorry, didn't help. 

It does seem to have made it at least try, because it got the cover art for the first playlist - but nothing more after that. Can't download playlists, can't play songs, can't even show the playlist. :(

 

I tried to reboot as well, no change.

 

Download and installation went fast and without hickups, so no problem with the connection. My other devices installed and connected without problems. I didn't try them until after the tablet was tested.

20190226_085925.jpg

Re: Spotify app on android won't play, show cover art or download

Moderator
Moderator

Hey @ellegaarddk,

 

Thanks for getting back to us.

 

Can you go through the following?:

  • Try an alternative connection (if on a public or office network try a private network, if possible)
  • Ensure your operating system is up-to-date
  • Are you using any cache-clearing apps? If yes, is Spotify set as an exception?

We look forward to your reply :) 

 

Have a nice day!

Daisy Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Re: Spotify app on android won't play, show cover art or download

ellegaarddk
Casual Listener
Already tried several different connections, no change. And other devices on the same network has no problem connecting and downloading from the same accouint. OS is Android and should be within compability (cant remember which one right now). Cache-clearing isn't used on this device (it is on others with no problem).
SUGGESTED POSTS