Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify bluetooth metadata wrong after first track with Pixel 6 and Android 12

Spotify bluetooth metadata wrong after first track with Pixel 6 and Android 12

Plan: Premium

Country: USA

Device: Google Pixel 6

Operating System: Android 12

 

I have searched all of the forums and tried literally everything with no avail. I just got my google pixel 6 and when I connect to my 2018 toyota camry bluetooth, all of the track metadata stops after the first track. When I skip tracks, still only the first song's metadata shows, while the other songs play.

 

I have tried all of the different AVRCP Bluetooth versions (1.3-1.6), restarted phone and they all show the same behavior. Weird thing is that my old Moto G Power (Android 11) that has the same version of spotify and same AVRCP version works flawlessly. I am starting to think it is an issue with spotify and Android 12. 

This is so frustrating! Please help if anyone has solved this issue, again it IS NOT the AVRCP version. I have tried that a million times. Thanks!

Reply
8 Replies

Same here with Pixel 4a and Android 12 in a Toyota RAV4. The only solution is to downgrade to some old App version but you miss new functionalities of Spotify. I already followed for months the other "official" topic for this issue but now it is marked as "solved". Unfortunately, not for everybody.

I confirm that this is not a matter of battery optimization nor AVCP versions. It worked properly with my Android 9 One Plus 5t. Please keep investigating the issue. 

What version of spotify are you using? I tried some older versions and cannot get any to work with my Pixel 6.

Agreed, please keep investigating this issue. 

version 8.7.44.968

Thats the same version I have. I saw this version posted on a different forum and tried it myself with no luck! Ugh

Plan: Premium

Country: ITALY

Device: Google Pixel 4a

Operating System: Android 12 and 13

Plan: Premium

Country: ITALY

Device: Google Pixel 6a

Operating System: Android 12 and 13

Hi there folks,

 

Thank you for reporting this and for the provided information.

 

We can confirm that we've let the right team know about this and they're currently investigating this.

 

We'll update you in this thread as soon as we have any news about this.

 

Have a great Friday and start of your weekend 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Thanks for the feedback. Hope to see a fix soon.

Suggested posts