Help Wizard

Step 1

NEXT STEP

Spotify liked songs filter not working

Spotify liked songs filter not working

Upgraded recently from an iPhone 6 to a samsung galaxy s21 ultra. I use my liked songs primarily for shuffle and I love using the filter for my different genres, however I can only see the most recently liked songs (only 1-3 songs or none at all depending on the genre) when I have over 3.4k. I have restarted the phone, downloaded all of the songs, logged out and logged back in nothing has helped. If someone could let me know what I could possibly do to fix this I'd appreciate it.

Plan

Premium

Device

samsung galaxy s21 ultra

 

Operating System

Android 

 

My Question or Issue

 

Reply
35 Replies

Hi, coming up to a year since the original report, any update

Phone: Samsung ZFOLD3

Spotify version:8.7.56.421.

Just an eta to all that posted on this thread may be useful and may stop future users posting until that eta is over. Maybe a message to all spotify users too just that the issue is know and you are working on it.

Also may be worth temporarily removing the genre filter until its done?

Has this issue been fixed? I have the same problem on a Samsung ultra 21 and the latest version of Android. 

I have over 2,000 liked songs and multiple filters, but I cannot side scroll the filters, though my husband on our Duo account, which is in my name, can scroll his Liked Song filters.

Samsung S22 user here. This has plagued me for some time as well, and on previous phones too. Galaxy note 8 and google pixel 3a. Love Spotify but wish they had a solution to this minor but annoying inconvenience. 

What annoys me is that my husband can use it on our Duo account, but I
can't - and the main account is mine! I do love Spotify and this is not
something I use very often, but at least I know I am not alone in having
this issue.

Thanks for that suggestion.  I use Chosic, but I haven't tried using it to filter my Favourite songs into genres - I'll give that a go.  What I really wanted was Spotify to fix the Liked Songs "filters", which filter my liked songs into genres, and for a while it was working but I couldn't get the list of filters to scroll across the screen.  However, the Spotify filters are currently working, but I'm also going to try Chosic to see if that gives me better results. 

They don't care

I'm also having this issue, been waiting for a about 6 months and I can't find a fix for this myself. Tried every possible fix online but it's still not working. Can't swipe though the genres despite being able to partially see the next one.

 

Android version:13

Spotify version:8.7.92.521

Screenshot_20230104-111103~2.png

This is happening to me as well on my iPhone 6+.

Has this been resolved yet??

It is not working for me either! never show the filter on the liked songs page

iphone 13 pro max

ios version 16.1.2

spotify version 8.7.94

 

Hi, I'm having the same issue. 

My Spotify version is 8. 8. 4. 518

My phone is Android Version 11

I'm having the same issue as well, the liked song filter has disappeared. The issue started today and I've tried to restart my device and install the app but the issue is still happening.

 

 

 

Yeah I've just recently had the same problem, this feature used to work for me but I have no idea why it stopped working now. I just get, "you have filter set which may hide some results" once I click on a category. But I haven't set any filters. 

Hi! I can scroll though the filters for liked songs, but, whenever I click on any of them it says there are no songs in that filter. It worked for a while and it suddenly stopped. I updated the app and it didn't help. I'm on a galaxy ao3s. 

I am having the same issue only started happening to me this week. When I select any of the genres in my liked songs list like the picture in this thread, it opens a page that says nothing available that a filter is preventing it. But it was working a week ago. I have a Samsung galaxy a32. 

Having the same issue. I read on another thread saying to make sure everything is up to date, log out then back in and the issue should be fixed. That did work for me but now every time I open the app I have to log out and back in to get the filters to work. Honestly it's pretty annoying to have to do that every time I want to use it.

Suggested posts