Help Wizard

Step 1


Spotify not showing song metadata on the car stereo (meanwhile, other android apps do this fine)

Spotify not showing song metadata on the car stereo (meanwhile, other android apps do this fine)




United Kingdom


Sony Xperia 1 II

Operating System

Android 11


2012 Toyota Auris 1.33


My Question or Issue

Hi all. When I connect my phone to the car's stereo with bluetooth, the name of the song appears for a brief second at the start of the connection, then vanishes, and remains invisible. This has been an ongoing issue for the past 2-3 years. But if I use any other media player on my phone, the metadata displays on the stereo without any issues.

  • Here is a video of the issue happening. I turn the car on, and the phone automatically connects via bluetooth. You can then see the song start to play, but the name disappears. I can scroll through the metadata, but it does not remain on the stereo.
  • Meanwhile, here is another song being played using the phone's native music app. You can see the metadata displaying correctly without any issues.

Important note: I am still able to navigate the songs with the steering wheel, even though the names do not appear.


Steps I have already tried to fix the problem:

  • I have restarted my device, and my car stereo
  • Ensure that I have the most up-to-date version of Spotify (
  • Ensure that I have the most up-to-date version of my phone's OS (Android 11)
  • Cleared the Spotify cache
  • Deleted all Spotify data on the phone, and did a fresh reinstall
  • I have all the permissions for Spotify turned "on" in the app settings
  • I have tried both car view on, and car view off
  • I have tried "Device Broadcast Status" both on, and off
  • I have tried connecting via USB, but this is not compatible with my car (see image)
  • I have turned on my phone's "developer mode" in the settings, and tried the following:
    • Attempted enabling Gabeldorsche
    • Tried disabling bluetooth A2DP hardware offload
    • Tested all the versions of Bluetooth AVRCP (1.3, 1.4, 1.5, 1.6)
    • Tested all versions of Bluetooth MAP (1.2, 1.3, 1.4)

As I had mentioned, this problem has been persisting with me for the last 2-3 years, going back to my previous phone (Samsung Galaxy S8+). Strangely enough, the metadata used to display correctly, until one day this problem happened and hasn't gone away since.

Any information or guidance would be appreciated, thank you.






2 Replies

Hi there @RashAttack,


Thanks for reaching out to the Community and welcome!


We're aware of this issue and the right teams are currently looking into it. We suggest adding your +Vote to this Ongoing Issue thread and Subscribe, as we'll be sharing any updates regarding this over there, as soon as there are any.


If you need anything else, the Community is here for you.



Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Hi Carlos,


Thank you, I will follow that topic and hopefully a solution is found soon.




Suggested posts