Announcements

Won´t play audio on BMW i3

Won´t play audio on BMW i3

I recently bought a Xiaomi Mi Note 10 ( running Andriod 9) and when I connect to my BMW i3 with Bluetooth I don’t get any sound when playing Spotify.

It works with other apps such as Youtube, Acast etc. The settings for “audio” is ON.

 

As soon as I try to play from Spotify I can see that it loses Bluetooth connection for a second and then reconnects but no sound.

Sometimes it plays for a fraction of a second and then just total silence.

 

I have tried to reinstall Spotify several times, also with older versions but without any luck.

Thinking about either selling the damn car or the phone. I hate them both right now. 😃

Reply
3 Replies

I´ll just go ahead and answer myself here 😃 

 

Found out that if I delete "data" it will work again until I stop playing. So every time I want to listen in the car I need to delete data. If this helps someone to find out whats wrong I would be very happy! 

What do you mean by "delete data"?

Hey @sejrsejr0025 and @rallypack,

 

Thanks for searching for the answer you need here!

 

It sounds like something is interfering with the apps cache, that's why the issue gets resolved after you clear your data. It's a good idea to perform a clean reinstall using the steps here, this way all necessary files get built up anew from the ground up. Afterwards make sure that there are not battery optimization or cache clearing apps activated for Spotify. Keep in mind that even if you never installed such apps, some phones have them preinstalled. 

 

If the issue persists, could you let us know which Spotify version you are running, as well as whether or not this comes up when you try to connect to other devices via Bluetooth? 

 

Hope this helps. Keep us posted on how it goes.  

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts