Help Wizard

Step 1

NEXT STEP

Wrong artwork cover on car's Bluetooth.

Wrong artwork cover on car's Bluetooth.

Plan

Premium

Country

Greece

Device

Nothing Phone 1 

Operating System

Android 13

Car

Hyundai Tucson (2021)

 

My Question or Issue

Mobile connected via Bluetooth (not android auto with cable, only Bluetooth).

Music plays from Spotify. The title and the artwork cover in the first track play well. In the next one, the title changes but the artwork cover remains the same as the previous one. On the 3rd track, you see title name change normally of the 3rd track but artwork cover of the 2nd. You move on to the next one and so on.

With another player everything works fine.

But since I'm very comfortable with Spotify, I'm struggling to make it work properly. I found some tips for changing the Bluetooth avrcp and battery optimization, but it's useless. The only thing I managed to do is not to show the artwork cover to any player by changing the Bluetooth avrcp but with the song titles changing correctly. In order to show the artwork cover it needs to have Bluetooth profile avrcp 1.6.

The infotainment of the car should not be to blame. It's most likely a Spotify bug after some update that I didn't hear about. It definitely has something to do with the Bluetooth avrcp profiles and how Spotify transfers the metadata to the car's infotainment.

In other players of my mobile the artwork cover changes normally. Like something sticks and stays in the artwork of the previous song while the next one is playing. It transfers the metadata, but laterally.

Is there any solution because it is very frustrating? I am very comfortable with Spotify and would not like to remove it.


Thanks in advance

 

Reply
Top Answer
AlejaR
Moderator

Hey folks,

 

Thanks for all your replies and for the info shared.

 

We've gone ahead and passed your reports to the right team, and they're currently looking into this. However, we can't confirm when or if this will be fixed.

 

In that sense, we'd suggest you keep both the app and the car's receiver/unit up to date, so you won't miss any developments.

 

We'll be on the lookout!

79 Replies

I have exactly the same problem as you and have had it since the same day (Samsung S23 / VW Golf8 )
this has helped:

touch and hold Spotify icon

touch (i) icon (upper right corner of the window)

In-app notification settings

and nothing to set here just to go here by this way and immediately helps

That actually worked!

 

No idea why it worked lol but after doing this album artwork is now showing up on my car screen again.

 

Are you having to do this often or just once?  I'll see if it just keeps working now or if I have to do this every time I get in the car.

 

Very strange why this seems to fix it though but thanks for the help!  It was really annoying not having that album artwork showing! 

 

I'm glad it helped you too.

I came up with this solution just a day ago, but it's been stable ever since, and I've had the opportunity to listen to dozens of songs for a couple of hours and a few car starts.
In my case, the problem first appeared on 9 March 2024.
However, it cannot be ruled out that the problem will return at some point after the next Spotify update. They rather need to fix it in their software. The solution is strange indeed, because this place is nothing more than Spotify's settings panel and you can go there from the program itself, and yet, although I think I was doing that too, but going there standard way did not help.

dgian, as of today, Spotify reverted to its previous, original behavior for me, without any update of the Spotify app. Still running 8.9.20.574.

 

The first played song has either the correct album cover, or no cover at all. All subsequent songs have the previous album cover, again.

 

There have been no updates to my Fairphone or to the car infotainment software.

Yes we reverted the change since it caused the different wrong behaviour that you observed.

 

Will let you know once we have a new fix in place.

Hi GoldSpoon, thanks for your reply. But, given the timing I guess what you have seen is just the result of dgian trying to fix the issue of this thread (that the wrong album cover is being shown on their car for some people). To validate this, Spotify was shortly getting patched, which resulted in no album art being shown anymore. This has just been reverted.

Hi folks, there was a change to Spotify a few days ago in order to attempt to fix this issue here: https://community.spotify.com/t5/Android/Wrong-artwork-cover-on-car-s-Bluetooth/m-p/5930570/highligh...

This change has been reverted a few hours ago, see: https://community.spotify.com/t5/Android/Wrong-artwork-cover-on-car-s-Bluetooth/m-p/5940819/highligh...

So, I guess there was no solution necessary from anybody and what you have been seeing is just the result of Spotify getting changed...? Which would also fit in with your statement above: "The solution is strange indeed, because..."

Just my thoughts without having more insight into the matter, though.

ciao 🙂

Got the exact same problem in my Hyundai Tucson NX4. IPhones work well as other players on my android do. Definitely a Spotify bug.

Hi dgian, just FYI: With Spotify app version 8.9.24.633, I still have the wrong artwork cover being displayed via Bluetooth in my car (the last played song). So, no change as of now.

Any idea of how and when to tackle this issue again?

I don't have screen to display, as my car is a 2013, but I am still having issues with track/artist information on my radio display saying "Not Provided" for everything. It does display the songs initially and will occasionally stay that way, but only if I don't try to skip or change to a different song. I am also having issues with it jumping between stations/songs/podcasts randomly when switching between Bluetooth devices and also playing directly from the phone.

I am also having the same problem. App version is 8.9..24.633. The car is a BMW 2.25 with the latest software (not that it matters, I connect using the regular BT connection, not even Android Auto).

Maybe some additional behavior of the bug, Spotify mostly displays the wrong art work but after 4-5 songs, it displays the correct one. I can't tell which one it picks for the correct song. Feels like random. Also, in some songs, there is absolutely no art work at all. Again, it feels like random behavior. If there is a log file that I can pull out, I may try to copy it to here. Just tell me where the log file is.

Further details. I checked the issue in a Mercedes with MBUX system. The issue persists, so it is definitely not the car (BMW/Mercedes etc.). I noticed in the Mercedes that when the song changes, the correct album art is displayed for a second but then returns to the previous song's album art.

My guess is, by looking at the problematic handsets (Xiaomi, Oppo, OnePlus etc.), the Chinese handsets implement the album art in a way that is either not consistent with the BT standard or interpreted the standard in a different way.

The only solution I could find is to switch to Android Auto. In Android Auto, the album art is displayed correctly every time.

Please let me know if anything changed with the most recent version, 8.9.30. I did some changes but the landscape of Bluetooth is both vast and complex causing different devices behave differently.

 Thanks for the response.

I am still in 8.9.26.592. Once the 8.9.30 rolls out, I will test and let you know.

Unfortunately after the latest update there are again no more artworks at all.

Except when you pause/start the song. Then the cover appears.

Oh wow, you're right 😅

 

Now it's even the right artwork cover for each song, but as @lezebe wrote, only after you pause the title.

Has anyone of you tried with different versions of AVRCP?

 

It's something hidden under developer settings of your Android phone.

Developer Settings -> Bluetooth AVRCP Version -> try setting it to 1.6 and restart

 

Not that this will help for sure, but I am a bit at a loss here. We have yet to find someone internally with a combination that is broken like this.

The latest version has fixed the problem for me. Artist covers are visible and correct. I don't have to pause the song for it to work.Jumping between songs also works.


Bluetooth AVRCP version is set to 1.6.

 

I'm not sure if it was a data transfer issue, but 2-3 songs didn't transfer covers, but 90% of the time it worked.

 

Spotify: 8.9.30.433
Phone: Xiaomi Mi 12 5G (MIUI 14.0.15)

Android Version: 13

Car: Kia Sportage NQ5 (2023)

Suggested posts