Announcements

Help Wizard

Step 1

NEXT STEP

Smart shuffle ruins offline experience

Reply

Smart shuffle ruins offline experience

I have an iPhone 12 and iOS 16.5.1 and Spotify Premium specifically for the offline downloads and ability to turn shuffle off. However, since the addition of Smart Shuffle, I can’t turn off shuffle when offline. If the playlist is already in shuffle mode when offline, an error appears when I try to turn it off because it is trying to switch to Smart Shuffle instead of just playing the songs chronologically. The error says “Something went wrong. Go back and have another go?” Smart shuffle is already frustrating enough online because of how long it takes to switch between the different modes but it has made my offline experience significantly less enjoyable. The “enhance mode” was a much better feature for Spotify to recommend songs for personal playlists. Please include an option to disable smart shuffle permanently. 

IMG_1921.png
1 Reply

 

Plan

Premium

Country

 

Device

Pixel 7

Operating System

Android

 

My Question or Issue

Spotify doesn't play any song from the Liked Songs playlist in offline mode if smart shuffle is also enabled.

If I manually switch the playlist to regular shuffle or no shuffle, then the issue is resolved.

Steps to reproduce:

- turn off internet & mobile data

- go to Spotify and open Liked Songs playlist

- enable smart shuffle

- try to play any song - it shouldn't work 

- change to regular shuffle / no shuffle and try to play a song again - this should work

 

It would help if smart shuffle would just fall back to a regular shuffle in offline mode, so I don't have to manually turn it off every time I go offline.

Suggested posts