Google Chromecast not showing up in Spotify Connect (Android)

Reply

Google Chromecast not showing up in Spotify Connect (Android)

Cottand
Regular

Hi, 

I have Googe's Chromecast, my model is the NC2 6A5, and after setting it up, updating the firmware, and all that stuff, it works perfectly with all my apps but spotify. The exact issue is the little "Spotify Connect" button in the now playing screen not showing up. When I go to settings and tap on Connect, the device list is empty. I have a Moto g3, with Android 5.1.1. and the latest version of the Spotify app as of today. Other devices (such as my computer with Spotify desktop running on it) do show up and work. I'd appreciate any help, thanks.

 

Cottand

13 Replies

driveflanger
Community Legend

Hi. are both devices on the same network?

Cottand
Regular
Yup, same WiFi network. Other apps wouldn't work if they weren't I guess

driveflanger
Community Legend

Uhm try to reset the chromecast. I have one that it's first gen, and it works fine. 

Cottand
Regular

Nope. Didn't work, sorry. Mine is 2nd gen

driveflanger
Community Legend

Is the casting option working? Could you cast your screen to see if it works?

Cottand
Regular

Yeah, so far everything I've tried (Netflix from both my phone and my computer, YouTube from an iPad too, Toaster Cast, and screen casting too) has worked as expected, but Spotify, wich is what made me think it wasn't an issue with my device but with the app.

driveflanger
Community Legend

Uhmmm....do you have installed the chromecast app on your mobile device? from there you could try spotify connect.....Also, check the following that is very important too:

 

Spotify Connect

Free: You don’t have access to Spotify Connect.

Unlimited: You don't have access to Spotify connect.

Premium: You can use Spotify Connect. It lets you control music between your devices. While playing a song, for instance, you can switch playback from your phone to tablet or even to a connect-enabled speaker, as long as they are on the same Wi-Fi network.

Cottand
Regular

I do have Spotify Premium, so that shouldn't be an issue. Yes, I do have the Chromecast app, how do I use Spotify Connect "from there"? Tapping the Spotify icon under the "Your music and audio apps" section will just launch the app normally.

driveflanger
Community Legend

so to be clear, your mobile device doesnt see even the other devices running spotify? So if its the app itselft, you could try installing a different version to test if it works...you could go to http://www.apkmirror.com/?s=spotify&post_type=apps_post and look for the spotify apks

Cottand
Regular

As I said, it does recognise other devices (such as my laptop) but not my chormecast. That's all.  I'll install the apk tomorrow, I'll post whatever results I get. Thanks for the help though! It's great to have you answering this quickly.

Cottand
Regular

I've installed Spotify v4.3.0.922 and no results. I found this thread tho https://community.spotify.com/t5/Help-Android/Problem-with-Moto-G3-and-Chromecast-2015-video-version... anything you can tell me, DriveFlanger?

driveflanger
Community Legend

Uhmm it seems that it's a very specific problem with the combination G3+chromecast+spotify. Since Spotify connect has already been tested with other devices and it's working with them, and the chromecast is updated....maybe the fastest solution it's updating Android on the G3 as another user claimed it fixed the problem.

 

Flashing has potential issues, I'm not saying that it shouldn't been done (I myself have done it on tablets and phones and never had issues before), but If you are willing to do that, you have to be careful because it will void your warranty. You could google webpages that have posted the process of doing that.

 

Another thing would be to wait for a official update from LG and see if it fixes the problem, of course that would be taking a passive role.

Cottand
Regular

Well I must say I have considered installing CM before, and my bootloader is already unlocked so my warranty doesen't mean much anymore. Thing is I have stock LL 5.1 with Xposed such as GravityBox and stuff, and I think it's a more stable and less dangerous solution than flashing. So anyways, thanks for your help so far, but I'd say we've come to a dead end, haven't we? I guess this thread will stay in the air, maybe someday someone will find a solution that doesen't involve tampreing with the firmware. Please keep the thread up to date if you ever find anything relevant!

 

P.S.: Moto G is by Motorola by the way. Not LG. Maybe the issue will get fixed on the MM 6 update.

SUGGESTED POSTS