Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Blurred Screen on Car Thing

Solved!

Blurred Screen on Car Thing

Plan

Premium

Country

USA

Device

iPhone 12

Operating System

iOS 14

My Question or Issue

The screen on my Car Thing appears blurred when navigating thru pages. After some time on a single page it starts to 'clear up' but this is very distracting when scrolling through a playlist or my library. Attached are some examples. Does anyone else have this issue or a fix? I have tried factory resetting.

 

Podcast.jpg
Media.jpg
Fixed.jpg
Reply

Accepted Solutions
Marked as solution

The issue did resolve itself however it was not because of anything I had
done. One day it just randomly started working as suspected. My guess is it
has to do with the extreme warm weather we had when I first received the
device. I would try it out in your home overnight with a USB charger you
have and see if that clears it up.

Good luck

View solution in original post

10 Replies

Hi @AlexR666,

 

Thanks for reaching out and welcome to the Community!

 

Could you try switching the outlet you're plugged in? If you have the Car Thing connected to the cigarette lighter, please switch to a USB outlet and vice versa.

 

Keep us posted on how it goes.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hey @AlexR666 

 

That doesn't look normal to me. I haven't had this happen to the screen on my Car Thing.

 

Have you tried any other troubleshooting steps? Is this still happening?

MattSudaSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Thanks for the responses. I tried the USB port in my car rather than the cigarette lighter but got an error saying to use the adapter that was included with the device.

 

I am getting the streaky screen with the original adapter still. Also tried an additional USB adapter I had but same result unfortunately.

DiffAdapter.jpg
Playing.jpg
Home.jpg

Hey @AlexR666,

 

Thank you for getting back. 

 

In this case we recommend reaching out to our Car Thing support team using one the "Contact us" option here, and then following the route for Car Thing. They'll happily take a closer look and recommend how to best resolve the issue.

 

Cheers!

JulianModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Thank you - I have been in touch with support and sent some additional videos of my issue.

 

I will follow up here if it is resolved.

Car Thing can be plugged into a USB port as long as long as it has enough power. Usually it needs at least 12W. Your car's USB port probably doesn't have enough power which is usually the case when it comes to car USB ports.

 

In my opinion this looks like an issue with the screen itself and not software / power related but support should be able to help you get this sorted.

MattSudaSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Interestingly enough, the issue has resolved itself without any further action and has been working as expected for about a week or so now. Thanks for the quick responses all!

Hi there @Eedenn,

 

Thank you for your reply and confirmation.

 

We're really glad to see that everything works as it should for you.

 

Let us know if we can help you with anything else 🙂

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Did you do anything to fix this issue? Mine has started this same issue its been about 5 days now. Any info on how to resolve this would be appreciated. 

Marked as solution

The issue did resolve itself however it was not because of anything I had
done. One day it just randomly started working as suspected. My guess is it
has to do with the extreme warm weather we had when I first received the
device. I would try it out in your home overnight with a USB charger you
have and see if that clears it up.

Good luck

Suggested posts