[FIXED] Disable 'Connect to a Device' Reminder

UPDATE: This problem is now sorta fixed, because the blue bar has been replaced by a less distracting blue tick on the Connect icon. Below a screenshot for how it looks. 

This idea can now be marked as 'Fixed'.

spotifytick.png

  ============================================================

When I fire up Spotify, the blue bar with "Connect to a device" from Spotify Connect always comes up, even when I click the X and restart. So the bug is: it is not being saved in settings/cookies/whatever that I clicked the X and that I dont want to see it again.

 

Here is a video I made where I reproduce the bug: you can see it from 0:29 - 1:03

<video unavailable>

Updated on 2018-06-16

As mentioned, this should be less intrusive now with the latest Desktop Updates. ;)

Related Ideas

Comments
RhysHovell2
Newbie
 
Rock Star 21
Rock Star 21
Status changed to: New Idea
Updated: 2016-11-26

Marked as new idea.



gardykojr
Newbie

This is defintely getting annoying. Two updates since the redesign and it still hasn't been fixed. Plus removing notifications on new releases as a 'feature'.......c'mon guys. You're better than this.

donmccurdy
Newbie

I use Spotify on several devices, and on desktop I'm constantly seeing the blue "Devices Available" banner. I like the cross-device listening feature — I use it often enough. But it's pretty frustrating seeing the banner repeatedly, and having to dismiss it manually, when I'm perfectly aware that I have Spotify on other devices. I see the banner a couple times per week.

 

As a user, I don't want to be prompted to actively dismiss the same messages that don't affect me. I'm aware of the cross-device listening feature, so further interruptions from the banner are a distraction. 

 

I'd love to see a change along any of these lines:

 

a) Banner dissapears automatically after 30s.

b) Banner offers a "Don't remind me again." option.

c) Spotify advanced settings offer a "Don't remind me about available devices." option.

d) Banner does not appear after a user has made use of the cross-device playback feature 1-2 times.

tchaudhri
Newbie

+1 - would love to get rid of this constant reminder. Thanks!

bakman
Gig Goer

+3021 Highly annoying bar, if users want to connect to another device they will know where to find it by now. Thus: remove it yesterday.

Niwa
Newbie

Very annoying!! I usually play through my htpc connected to the 55" TV, that blue ribbon is very distracting and just plain pain! 
I KNOW that there is spotify connect units available..... I do not need this showed up my face every time i open spotify!

 

Fix this now please! :)

strdup
Newbie

This "devices available" bar is ridiculous. Please add a setting to disable it. Presumably people know that they have other devices in their house that they can play music too.

danc0hen
Newbie

Very annoying message, I get it you can use other devices, please stop this popup appearing or give me the ability to dismiss it forever

shaunparker
Newbie

I've tried every reasonable way to get Spotify to listen. They don't care. So here's the solution for people on OS X (You can do a similar thing on Windows, but the files are apparently in the "App Data" folder):

 

The basic gist is that Spotify's application is storing whether or not to display this annoying message in a session variable named "remote-playback-bar-closed". My solution edits the Spotify's zlink application to always set the _availableDevicesMessageHidden property of the RemotePlaybackBar to always be true. Right now, this is line 16,196 of /Applications/Spotify.app/Contents/Resources/Apps/zlink.spa/bundle.js:

 

    this._availableDevicesMessageHidden = _knockout2.default.observable(sessionStorage.getItem(SESSION_STORAGE_KEY) === 'true');

 

the steps below changes it to:

 

    this._availableDevicesMessageHidden = true;

 

To do this, open the Terminal application and run these commands:

 

cd /Applications/Spotify.app/Contents/Resources/Apps

#make a backup of the original for safety

cp zlink.spa zlink.original.spa

#unzip the zlink.spa file into zlink folder

unzip -a -d zlink zlink.spa

#force the available devices message to always be hidden

sed -i.backup 's/this\.\_availableDevicesMessageHidden \= .*/this._availableDevicesMessageHidden = true;/g' zlink/bundle.js

#update bundle.js in zlink.spa

zip -fj zlink.spa zlink/bundle.js

 

You should be good, just restart Spotify.

 

I hope that helps. Just note that you'll probably have to do this every time Spotify updates their app.

 

I think it's insane that Spotify isn't fixing this. I think it'd take any one of their engineers 10 minutes.