Invalid URI

Reply

Invalid URI

CelestialInfern
Casual Listener

I keep trying to post my playlist in the playlist exchange to no avail. Every time it successfully looks up the playlist but then when I try to post it, it says it is invalid. I've tried both URI and HTTP formats in multiple different ways. Copying to clipboard. Etc. The result is the same everytime. Except in one of the instances it somehow actually let me post but it posted it saying "sorry we can't find that"

 

Now my post is up but no one can see the playlist. Looks pretty dumb haha. 

 

Someone else posted about this and someone said their username having a special character was a problem. My last name has a special character too. But it is my last name. I shouldn't have to make a new account and change my name this is ridiculous. 

 

I already have a ton of likes on my playlists, I'd be starting from scratch if I did that. 

2 Replies

Re: Invalid URI

mosohodPeti
Composer

Hi there @CelestialInfern!
Have you checked if the playlist you're trying to share isnt set to private?

Highlighted

Re: Invalid URI

pjPug
Roadie

This started happening to me about a week ago and I just figured out the problem. If the URI copied from the app doesn't work, try inserting your user ID (NOT the display name, which is different for newer users) into the URI.

For example, instead of:

spotify:playlist:xxxxxx

try this:

spotify:user:xxxxxx:playlist:xxxxxx

You can see the user ID in your Account Overview. For newer users it will be system generated, containing a string of random letters and numbers.

SUGGESTED POSTS