Stop Spotify from launching on startup

Reply

Stop Spotify from launching on startup

Music Lover
‎2012-09-28 05:40 PM

Every time I start up my Mac (10.7), I get a dialog box saying something like "Spotify is requesting confidential information from the keychain -- allow/deny?"

 

I do not want Spotify launching at startup. I went into Spotify's prefs and made sure it's set to "don't" launch at startup. I also checked in my System Preferences > User Accounts > Login Items and made sure Spotify isn't there.

 

Yet it's still requesting my passwords from my keychain upon startup. I don't want this. How do I switch it off?

21 Replies

Re: Stop Spotify from launching on startup

Spotify Legend
‎2012-09-28 06:29 PM

Two issues here, I think.

 

Start-up on login:

 

You'll find that on the bottom of the page in Preferences.

 

Keychain access

 

Spotify wants to remember your (Spotify) password. You'll get this the when you start Spotify manually. If you accept, you won't get it any more.

 

Re: Stop Spotify from launching on startup

Music Lover
‎2012-09-28 06:31 PM

Jude, on the first issue, I already mentioned that I disabled that.

 

On the second issue, I'm not launching Spotify *at all* and it's still asking for keychain access. Therefore, it *is* launching (or some daemon of it) on startup, and that's what I want to stop. I don't want unnecessary background processes running on my computer. I don't want to click allow. I want it to not to try to connect at all.

 

Or just tell me how to remove the whole thing.

Re: Stop Spotify from launching on startup

Spotify Legend
‎2012-09-28 07:02 PM

Sorry. I didn't notice that you had already turned it off.

 

Have a look in your Keychain (Spotlight: "Keychain access"). See if there's anything Spotify in there.

 

 

Re: Stop Spotify from launching on startup

Music Fan
‎2012-10-08 11:59 AM

You do not seem to be answering the question.

 

There is an intrinsic flaw in Spotify's code that is overriding the preferences set both in the application and in system preferences. 

 

I have the same problem: Spotify preferences set to Don't open automatically; Spotify is not one of the system startup items. Guesss what happens evry time I start up? And Spotify often prevents shut down.

 

I am one step away from complete de-install of an applicatiobn that I would otherwise love.

 

Please advise on any other way to prevent unwanted launch of Spotify.

 

Many thanks.

Re: Stop Spotify from launching on startup

Concert Regular
‎2012-11-23 06:59 PM

What "Preferences" are you talking about having this as an option at the bottom of the page?

PLEASE!  I want this to STOP!

Re: Stop Spotify from launching on startup

Spotify Legend
‎2012-11-25 03:56 PM

Spotify Preferences page can be reached from the Edit menu (Mac: Spotify menu).

 

Here's the relevant section:

 

Re: Stop Spotify from launching on startup

Concert Regular
‎2012-11-26 05:55 AM

Jude, where do you find this  Mac:Spotify menu?

Now Spotify is ALSO asking to allow password keychains when the mac starts up.  :-(

This problem is getting worse!  Help?

Re: Stop Spotify from launching on startup

Spotify Legend
‎2012-11-26 09:57 AM

The Mac is asking to access the password for Spotify that it has previously stored. It shouldn't have to ask more than once.

 

>> where do you find this  Mac:Spotify menu?

 

When running Spotify, Spotify menu > Preferences

Re: Stop Spotify from launching on startup

Concert Regular
‎2012-11-26 04:06 PM

Where is this Spotify menu that you speak of when running Spotify?

How do I get Spotify to STOP asking for my password keychain every time my computer starts up?

This is incredibly frustrating.

SUGGESTED POSTS