Announcements

ALSA Audio issue with new client 1.1.42.622.gbd112320

ALSA Audio issue with new client 1.1.42.622.gbd112320

Plan

Premium

Country

US

Device

Lenovo thinkcentre900 desktop

Operating System

Linux Mint 20 Cinnamon 64

 

My Question or Issue

I have been using Spotify client 1.1.10.546.ge08ef575 with direct output to my DAC via ALSA (after stopping Pulseaudio) to avoid any unnecessary conversions.

 

After upgrading to  .1.42.622.gbd112320 I get the following error in STDERROR:

ALSA lib pcm.c:8601:(snd_pcm_set_params) Sample format not available for PLAYBACK

 

No change in my ALSA or other audio setup.  It does play via Pulseaudio.

Downgrading the Spotify client rectifies the issue.

 

Can anyone enlighten what has changed in this latest release? Both clients set to maximum quality.

 

Thanks

Reply
2 Replies

Hey @atzan 

 

Could you tell me how you have set your sound up? I would try and look into it myself.
I am kind of surprised Spotify worked directly with ALSA, I thought it could talk to PulseAudio only.

 

🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

It took me long time to research this but in the end it is very simple:

Stop PulseAudio, which in Ubuntu/Mint 20 is done by systemctl:

 

systemctl --user stop pulseaudio.socket
systemctl --user stop pulseaudio.service

 

(reverese by replacing stop with start)


Ensure that yru DAC is the default device with no direct hardware output:

 

~user/.asoundrc =

pcm.!default {
type hw
card 1
}

ctl.!default {
type hw
card 1
}


Start spotify client (not the flatpak version). The "old" version starts normally and plays where the "new" gives the unsupported rate message.

 

When playing via ALSA my DAC indicates that it receives 16bits/44.1KHz stream, which is what I am expecting if there are no conversions.

Re-starting PulseAudio and the restarting the Spotify client I get 24bits/44.1Khz no matter what manipulations I do via ~user/.config/pulse/daemon.conf

Starting the Spotify Client with the option --show-console and searching "audio_driver" will report "Using PulseAudio" or "Using ALSA"

Looking forward to your exploration.

 

Suggested posts