Blank spotify client: Attempting to run unsupported native service: /usr/share/spotify/content_ren

Reply
Highlighted

Blank spotify client: Attempting to run unsupported native service: /usr/share/spotify/content_ren

handelhoven
Regular

 

Plan

Premium

Country

Canada 

Device

Asus FW series

Operating System

Ubuntu 18.04

 

My Question or Issue

On startup, the main window displays but it is a dark blank. 

 

Starting from terminal gives the message:

Attempting to run unsupported native service: /usr/share/spotify/content_renderer

Journal has the entry :

Oct 12 05:09:42 matenm kernel: traps: spotify[29503] trap int3 ip:7fecd483a643 sp:7ffcdf9d3e30 error:0 in libcef.so[7fecd4100000+53f1000]

 

  Installed using Debian install from https://www.spotify.com/us/download/linux/. As the installation begins there is a message about recommended packages, one of which is prohibited by the message parser a ffm mpeg extra 56. Odd that it is not permitted in the community but yet is suggested by the installer. Explanation of that will be interesting. 

Recommended packages:
  libavcodec-ffmpeg56 
libavcodec54 libavcodec-extra-54
libavformat-ffmpeg56
libavformat54

However the 18.04 repositories have no installation candidates for these packages. 

 

I am running spotify client without issue in Debian 9, and in another 18.04 machine so this appears to be particular to this configuration. Any idea how to fix? 

 

Thanks very much. 

1 Reply

Re: Blank spotify client: Attempting to run unsupported native service: /usr/share/spotify/content_

handelhoven
Regular

Actually it looks like the parser didn't like the inclusion of the field separator that the installer uses. It was not reacting to the package name. Sorry.

 

SUGGESTED POSTS