Cannot update linux client higher than version 0.9.xxxx


Cannot update linux client higher than version 0.9.xxxx


Hey there!


I have a problem regarding upgrading to version 1.0.xxxx from 0.9.xxxx on linux. Neither Synaptic PM UI or my bash shell seem to be able to upgrade higher than 0.9. What can you suggest I do? I'm running:

3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux


The client works just fine, but I am missing my connect features because I run the music in my speakers from my phone at work. Hope you can help. So far I have tried 


sudo apt-get update

sudo apt-get upgrade

sudo apt-get autoremove spotify-client


rinse and repeat any of those. My package manager tells me that I have duplicate entries. I don't know if that can affect the version it fetches from your servers?


sudo apt-get update
Reading package lists... Done
W: Duplicate sources.list entry stable/non-free amd64 Packages (/var/lib/apt/lists/repository.spotify.com_dists_stable_non-free_binary-amd64_Packages)
W: Duplicate sources.list entry stable/non-free i386 Packages (/var/lib/apt/lists/repository.spotify.com_dists_stable_non-free_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems


1 Reply

Community Legend

Hey @IncrediblePony,


The package that is available via the repository is the latest stable version.

You can update to non-stable using the .deb package from here.

For 64-bit Debian:


dpkg -i spotify-client_1.0.17.75.g8f111100_amd64.deb

For 32-bit Debian:


dpkg -i spotify-client_1.0.17.75.g8f111100_i386.deb

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?