[Desktop][Linux][Playlists][Bug] Pasting songs in playlist freezes the application

[Desktop][Linux][Playlists][Bug] Pasting songs in playlist freezes the application






Lenovo ThinkPad P17 Gen2i

Operating System

Ubuntu Desktop 22.10 x64

App Version



My Issue

Linux client freezes with a cpu load of 100% when pasting songs/URLs from the clipboard if the data contains empty lines or the very last line is terminated with a newline, i.e. an empty line after the list.


Steps to Reproduce

  1. Open the Spotify Desktop App
  2. Select the 1st playlist
  3. Press CTRL-A, CTRL-C
  4. Open a text editor of your choice (e.g. gedit)
  5. Press CTRL-V in the editor
  6. Note: The very last line of the playlist is NOT terminated with a newline character
  7. Press ENTER at the end of the very last line to terminate it OR
  8. Press ENTER at the end of another line inbetween to add an empty line
  9. Note: One of step 7 and 8 is sufficient
  10. Press CTRL-A, CTRL-C in the editor
  11. Go back to the Spotify Desktop App
  12. Select 2nd playlist for pasting
  13. Press CTRL-V in the Spotify Desktop App
  14. Watch your currently running processes (e.g. xterm -e top)


Observed Behaviour

The Spotify Desktop App becomes (mostly) unresponsive and the process produces a 100% load on that one single core where it is actually running. The app will never return and must be killed.


Expected Behaviour

When pasting ANY text data the app should parse that data for any valid URLs and add them to the playlist within a reasonably short amount of time without freezing. Copying a whole message from a WhatsApp or e-mail containing some URLs would be a common use case.


Additional Remarks

This behaviour is reproducible: After experiencing the problem on my desktop machine, I was able to reproduce exactly the same behaviour on a blank machine by installing the operating systen, the desktop app and following the steps mentioned above. Deleting ~/.cache/spotify and/or ~/.config/spotify or reinstalling the application also did not help.


Please fix.

Thank you.



1 Reply

I'm on Arch Linux and I confirm this. I've had this issue for more than a year at this point.


I've tried all installation methods: spotify-launcher, official snap and AUR. I tried removing configuration and cache. Nothing helped. I'm pretty sure this is the first mention I've found of this exact bug.


In my case, this doesn't significantly add CPU load, but some apps like Telegram and Slack also end up freezing. They all unfreeze after a minute or two.


The issue does seem to be related to newline characters, however for me it's not necessary to manipulate tracks in a text editor after copying from Spotify client to reproduce this. It gets pasted fine after I pass the copied links through the text editor.


Another Arch user also reproduced the issue. You can also find my log in that thread. This forum filters my post when I post it for some reason.



App version 1.84.716.gc5f8b819-2

Suggested posts