[Linux] [Debian] Spotify Client 1.0.15: No music hearable

Solved!
Reply
Highlighted

[Linux] [Debian] Spotify Client 1.0.15: No music hearable

Regular

Hi,

 

after upgrading from 1.0.14.124.g4dfabc5 [1] to 1.0.15.137.gbdf68615 [2] all seems fine, except a major problem, I don't hear a darn thing 😉

My songs are playing, but I can't hear the music. After downgrading to 1.0.14.124.g4dfabc5 I hear the music again.

I'm using your "testing" Debian repository [3] and my operating system is a Debian Testing.

If I start spotify from a terminal, I can't see a explicit error about a sound issue.

 

Can you please investigate?

 

 

[1]

$ spotify --version 

Spotify version 1.0.14.124.g4dfabc51, Coyright (c) 2015, Spotify Ltd

 

[2]

$ spotify --version
Spotify version 1.0.15.137.gbdf68615, Copyright (c) 2015, Spotify Ltd

 

[3] deb http://repository.spotify.com testing non-free

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Spotify
Spotify

Can you try version 1.0.17 that was just released and see if it works. Pulseaudio is not a required dependency. This is just a case of bad programming and testing.

View solution in original post

26 Replies
Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Community Legend

Hello @Schnoogemetzger,

 

Please note that the version you are using is non-stable.

However, it sounds like Spotify is using the wrong output channel ( common issue with Debian ).

 

You can play around with the sound manager and see on which channel Spotify is working. ( If there is no channel available Spotify will start skipping songs. )

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Regular

Hi @

 

> Please note that the version you are using is non-stable.

Jepp, I know. But a problem is a problem and I'll be patient, because it is non-stable 😉

 

> However, it sounds like Spotify is using the wrong output channel ( common issue with Debian ).

I unmuted several channels, but no luck so far. Is there a config file to adjust the channel output? Or at least, can I see in the log file, which channel is used?

 

> ( If there is no channel available Spotify will start skipping songs. )

Ahh, after 30-40 sec. the song skips to the next one. So, it seems to me, spotify doesn't find the right channel.

Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Community Legend

Hello @Schnoogemetzger,

 

I would suggest you to use PulseAudio as sound manager in Debian 🙂

If you still have issues with the sound, please give me the output of the following commands: 

 

 

lsof /dev/snd/*
fuser -v /dev/snd/*

 

 

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Regular

>I would suggest you to use PulseAudio as sound manager in Debian 🙂

Hmm, I don't know. I'm considering. PulseAudio isn't a requirement, so far? I mean, you can only help further, if I use PulseAudio?

I will test spotify on another box.

In the meantime, my output from lsof and fuser about the sound devices:

Output without spotify running:
$ lsof /dev/snd/*
COMMAND     PID  USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
xfce4-vol 12190 <USER>  9u   CHR  116,2      0t0 17199 /dev/snd/controlC0

$ fuser -v /dev/snd/*
/dev/snd/controlC0:  <USER>     12190 F.... xfce4-volumed

With spotify 1.0.14:
$ lsof /dev/snd/*
COMMAND     PID  USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
xfce4-vol 12190 <USER>  9u   CHR  116,2  0t0 17199 /dev/snd/controlC0
spotify   30355 <USER>  mem  CHR  116,3      17489 /dev/snd/pcmC0D0p
spotify   30355 <USER>  96r  CHR  116,33 0t0   317 /dev/snd/timer
spotify   30355 <USER>  97u  CHR  116,3  0t0 17489 /dev/snd/pcmC0D0p
spotify   30355 <USER>  101u CHR  116,2  0t0 17199 /dev/snd/controlC0

$ fuser -v /dev/snd/*
/dev/snd/controlC0:  <USER>     12190 F.... xfce4-volumed
                     <USER>     30355 F.... spotify
/dev/snd/pcmC0D0p:   <USER>     30355 F...m spotify
/dev/snd/timer:      <USER>     30355 f.... spotify

With spotify 1.0.15:
$ lsof /dev/snd/*
COMMAND     PID  USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
xfce4-vol 12190 <USER>  9u   CHR  116,2  0t0 17199 /dev/snd/controlC0
spotify   31734 <USER>  mem  CHR  116,3      17489 /dev/snd/pcmC0D0p
spotify   31734 <USER>  96r  CHR  116,33 0t0   317 /dev/snd/timer
spotify   31734 <USER>  97u  CHR  116,3  0t0 17489 /dev/snd/pcmC0D0p
spotify   31734 <USER>  98u  CHR  116,2  0t0 17199 /dev/snd/controlC0

$ fuser -v /dev/snd/*
/dev/snd/controlC0:  <USER>     12190 F.... xfce4-volumed
                     <USER>     31734 F.... spotify
/dev/snd/pcmC0D0p:   <USER>     31734 F...m spotify
/dev/snd/timer:      <USER>     31734 f.... spotify
Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Community Legend

Hey @Schnoogemetzger,

 

PulseAudio is not mandatory, I will be able to help you in either way.

Can you please let me know the output of the following line: 

 

 

 

aplay -l

 

 

If this solved your issue - Mark it as a solution!
Twitter | Website |
What's a Spotify Rock Star, and how do I become one?



Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Casual Listener

No audio for me neither. Going back to 1.0.14 solved it. These command outputs are with 1.0.15 running and playing music.

 

$ lsof /dev/snd/*
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME spotify 17173 myuser mem CHR 116,3 14531 /dev/snd/pcmC0D0p spotify 17173 myuser 98r CHR 116,33 0t0 10011 /dev/snd/timer spotify 17173 myuser 99u CHR 116,3 0t0 14531 /dev/snd/pcmC0D0p spotify 17173 myuser 100u CHR 116,2 0t0 14530 /dev/snd/controlC0
$ fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  myuser     17173 F.... spotify
/dev/snd/pcmC0D0p:   myuser     17173 F...m spotify
/dev/snd/timer:      myuser     17173 f.... spotify

 

 

$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Regular

Same problem with OpenSuSE Tumbleweed, the others multimedia applications work without problem, except 1.0.15.

 

 

I returned to 1.0.14 and it is working well.

 

Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Newbie

I'm on Ubuntu 15.10 and I have exactly the same problem.

 

Today was a new version of Spotify in updates but it diddn't resolve this bug.

 

$ spotify --version

Spotify version 1.0.16.104.g3b776c9e, Copyright (c) 2015, Spotify Ltd

 

Also there is one more user with this problem and he posted in this thread:

 

https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Pulse-Audio/td-p/1221343

Highlighted

Re: [Linux] [Debian] Spotify Client 1.0.15: No music hearable

Casual Listener

Since 1.0.15 (and 1.0.16) audio is no longer working for me too (Debian, no Pulseaudio, kernel 4.2).

SUGGESTED POSTS