[Linux] Local files do not play on Ubuntu 16.04 [SOLVED]

Solved!
Reply

[Linux] Local files do not play on Ubuntu 16.04 [SOLVED]

ramedeiros
Regular

Hi, I have installed ubuntu-restricted-extras, ffmpeg, libavcodec, livavutil, libavformat, zenity but doesn't work.

 

😕

 

  1. Your device and operating system: Intel® Core™ i3 CPU M 330 @ 2.13GHz × 4, 4GB, 64bit, Ubuntu 16.04 LTS
  2. Type of Spotify account you have (Free/ Premium): Free
  3. The app version of Spotify you’re using: 1.0.28.89.gf959d4ce
  4. Brief description of the issue: Local files do not play on Ubuntu 16.04

Spotify finds the songs, but don't play and close the app. 

 

 

=======================================================

Solved after read this post: https://community.spotify.com/t5/Help-Desktop-Linux-Windows-Web/Can-t-play-local-files-with-current-...

 

So, I decided publish the solution.

 

1º) Install some packs: ubuntu-restricted-extras, ffmpeg, libavcodec, livavutil, libavformat, zenity.

 

sudo apt install ubuntu-restricted-extras ffmpeg libavcodec-extra libavcodec-extra57 libavutil55 libavformat57 zenity -y

New version to packs: libavformat57 libavcodec-extra57 libavcodec-extra libavutil55 

 

 

2º) Download some archives: (I put all in the github repository)

 

--> Download the package: https://github.com/ramedeiros/spotify_libraries/archive/master.zip

 

Or direct from the terminal: 

 

git clone https://github.com/ramedeiros/spotify_libraries.git

3º) Put all the files in to /usr/lib/x86_64-linux-gnu/ with root privileges.

 

cd spotify_libraries
sudo cp lib* /usr/lib/x86_64-linux-gnu/

4º) Execute: ldconfig

 

sudo ldconfig

5º) If show any problem with link, make new links.

 

e.g.: "/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libavutil.so.52 it's not a symbolic link"

So, execute command:

 

sudo ln -frs /usr/lib/x86_64-linux-gnu/libavutil.so.52.6.100 /usr/lib/x86_64-linux-gnu/libavutil.so.52
sudo ln -frs /usr/lib/x86_64-linux-gnu/libavformat.so.54.36.100 /usr/lib/x86_64-linux-gnu/libavformat.so.54
sudo ln -frs /usr/lib/x86_64-linux-gnu/libavcodec.so.54.71.100 /usr/lib/x86_64-linux-gnu/libavcodec.so.54

 

And so on...

1 ACCEPTED SOLUTION
Solution!

olejon
Roadie

Easier solution. It works on Ubuntu 16.10 and 17.04 as well. Make sure you copy the entire lines: https://github.com/olejon/spotcommander/wiki/LocalFiles


And COME ON Spotify, 16.04 is almost a year old!

 

SpotCommander - The most elegant, intuitive, feature-rich & universal remote control for Spotify, exclusive for Linux users!

View solution in original post

36 Replies
SUGGESTED POSTS