Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

[Linux] Spotify 1.0.24.104 on Kubuntu Xenial no local music files

[Linux] Spotify 1.0.24.104 on Kubuntu Xenial no local music files

Hello guys,

 

since Ubuntu 16.04 Xenial is just around the corner I gave this a try in a virtual machine. I'm using the Kubuntu flavour.

 

The good:

Spotify runs out of the box, you can install, start, login, and play right away.

 

The ugly:

Spotify cannot open file dialog boxes. On the command line it shows that it cannot find zenity, which is a tool to display graphical dialog boxes from shell scripts. I don't know if that's a fallback if it cannot use the possibilities of the desktop environment (plasma 5 here), or if that's default. Anyway, a "sudo apt-get install zenity" fixes that and file dialog boxes show up

 

The bad:

While I now can add local sources to spotify, nothing shows up under "local files". On the console output there is no sign that it even tries to scan anything, it just does nothing. No output.

 

I ran spotify through strace -f and searched in the output for any appearance of libav* stuff or ffmpeg stuff or anything, but no hits. So it even doesn't try loading any libavformat and avutil and whatever it tried in the past.

 

So I'd be interested in comments from curious beta sofware users and of course of the devs to work together debugging this.

 

Bye

Daniel

Reply
2 Replies

Well, turns out my test mp3s were broken. Tried with correct ones and voila, they show up in "local files". But then when playing them, spotify crashes with a segfault immediately.

 

But this time I caught spotify searching for libav stuff, it searched for libavcodec.so.54, then tried libavcodec.so.53 and then libavcodec.so.52.

 

No success of course, because Xenial comes with libavformat-ffmpeg56 and libavcodec-ffmpeg56 which installs

/usr/lib/x86_64-linux-gnu/libavformat-ffmpeg.so.56

/usr/lib/x86_64-linux-gnu/libavcodec-ffmpeg.so.56

 

Funny thing is, spotify did not even search for libavformat.so.56, although "strings -a /usr/share/spotify/spotify |grep libavformat" gives:

libavformat.so.56
libavformat.so.54
libavformat.so.53
libavformat.so.52

 

Sad thing that spotify does not provide its own libavcodec.so.54. it maybe works then. I guess I will now need to build an older ffmpeg version and put this lib into /usr/share/spotify.

So I went through all the dependencies and tried and retried and analyzed with ldd, and now I have these libraries copied from ubuntu trusty to /usr/share/spotify in my xenial system:

 

libavcodec.so.54
libavformat.so.54
libavutil.so.52
libfdk-aac.so.0
libgcrypt.so.11
libgnutls.so.26
libopenjpeg.so.2
librtmp.so.0
libvpx.so.1
libx264.so.142

 

Now I have full local file support.

 

I hope this helps others searching for a workaround and I hope devs will update spotify to work out of the box for xenial very soon.

Suggested posts