Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Linux Spotify (installed from snap) mini icon tray, indicator sound menu

Linux Spotify (installed from snap) mini icon tray, indicator sound menu

I recently install spotify from snap on Ubuntu 16.04, when playing music, the menu sound does not recognize spotify, so i cannot control music from menu sound.

Screenshot from 2017-12-24 20-37-51.png
23 Replies

I'm having the exact same problem on Ubuntu 16.04. Spotify 1.0.70 (installed from a snap package @ Ubuntu Snap Store) is not properly integrated with the sound menu in system tray. Spotify 1.0.69 (installed from a DEB package @ spotify repo) had the integration working. Didn't try 1.0.70 packaged in DEB though to blame solely Snappy packaging.


Any support on the issue would be much appreciated.

I also run Unity with Ubuntu 16.04 LTS and I see no difference in the Sound Settings between the debian package and the snap package. Looks like this for both:



What do you mean with "the sound menu in system tray" and what is the problem? I see this in my sound menu:


I can control the master volume on my computer with the slider and see current playing song in Spotify and control playback.

Yes, I meant the latter menu you posted. In my case, the Spotify section disappeared, having just the Rhythmbox one. In my sound settings, in the Applications tab, the Spotify icon is not recognized though as well.

I see this problem now as well. Either something has changed in the rest of my system, or more likely it has never worked well and we have just tested this on systems where you previously had the debian package installed.


A fresh snap-based install (purging all Spotify configuration files) has the same problem. So seems like previous deb-based installation doesn't affect a snap-based one in any way. It's either a bug in 1.0.70, or in the snap-based packaging itself (can't exclude the latter since the latest deb-based package is 1.0.69).

I'm seeing the same issue, the OS integration is broken.

Same issue, fresh install in xubuntu from software, ( clicking on link in spotify page) which installs from snap.

spotify  --version
Spotify version, Copyright (c) 2017, Spotify Ltd


I'm also unable to connect to my chromecast on the network, but on the same computer I can access it with the web player. Please fix this, it's completely broken! One of the main reasons I subscribed to Premium was because Linux was supported. Uninstalling for now until it's fixed.

I tried both snap and deb, same issue with both.

I'm having the same issue after having reinstalled spotify about a month ago. Any solution yet?

Same issue here.


Ubuntu 16.04

Spotify version

I got only solution is remove snap and then install from .deb package. So you all need to waiting for an update from developers of Spotify.

I can confirm installing it from deb repository also fixed the issue on my ubuntu 16.04

I'm using eOS and had the same issue with the snap version. I fixed it removing the snap version and installing the .deb package with apt-get, now the icon is correct!

Open the unity tweak tool and goto Unity->Panel->Volume->Default Player and select Spotify.desktop.

This worked out for me. 

Now when you click the volume icon it'll show the controls for spotify

Screenshot from 2018-05-07 01-57-57.png

Same here. Fixed removing snap version and installing the .deb package through apt.

@warhammer920 Setting default app via Unity Tweak didn't work for me. I'm on Ubuntu 16.04 though, perhaps you are on a fresher one.

Has anyone tried 18.04, same problem there?

I had the same issue with 16.04 (installed from snap, from .deb it worked) Running 18.04 now and the same issue is still present (installed from snap, havn't tryed .deb yet).

Suggested posts