[Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Solved!
Reply

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Spotify
Spotify

@Lorenzo_NGG wrote:

Nope. No file dialog will appear. For me it’s just a “dead” button


That is another common problem with the debian package. It can probably be fixed with:

 

sudo apt install zenity

Since local files are optional, the package only recommends zenity, it does not depend on it. zenity is just a file picker used to select the directory where your local files lives. Then you also need the correct (old) version of libavcodec installed. It is probably easier to use the snap version.

 

sudo apt remove spotify-client
snap install spotify

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Lorenzo_NGG
Roadie

I do use the snap package

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Spotify
Spotify

@Lorenzo_NGG wrote:

I do use the snap package


Then you have found a new bug. :/ I will look into it.

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Lorenzo_NGG
Roadie

Thank You.

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

prashu20
Casual Listener

I am using ubuntu 17.10 and running gnome Wayland and have installed Spotify as a snap package but it doesn't allow me to add local files.The dummy Add a source button doesn't do anything. I have already installed zenity, ubuntu restricted extras and all other files but I don't get any popup to add new files and when I select a .mp3 file to open with Spotify, it never plays.

Please have a look into this and any help will be appreciated.

Thanks

spotifybug17.png

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

prashu20
Casual Listener

Forget to mention running version

Spotify version 1.0.70.399.g5ffabd56, Copyright (c) 2017, Spotify Ltd

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

mathieson
Newbie

Seeing the same issue of a dead button with Ubuntu 17.10

Highlighted

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Lorenzo_NGG
Roadie

Still there (the issue) with 1.0.72 snap package

SUGGESTED POSTS