Local Files doesn't work

Reply

Local Files doesn't work

kraxie
Casual Listener

Plan

Premium

Country

Sweden

Device

Desktop

Operating System

Manjaro Linux

 

My Question or Issue

Adding local files doesn't work. Enabling "Show local files" and adding sources doesn't add any files to the "Local files" tab. I've tried using .flac, .caf, .mp3 and .ogg, but none of the files are detected by Spotify.

 

Spotify version 1.1.10.546.ge08ef575, installed through AUR.

4 Replies

Re: Local Files doesn't work

alex22p22
Casual Listener

I've been seeing a similar problem myself in Debian 'buster' 64 bit with the latest spotify 1:1.1.10.546.ge08ef575-19.

 

When I go to settings I can select "Show Local Files"

This makes a "Local Files" option appear in the left hand pane.

 

But when I click on "Local Files", it displays the message:

"Play songs from your computer by adding them in Preferences"

 

Then I click on the "Go to Preferences" button which is displayed below that message and it takes me back to my settings again.

 

Then there is an option:

 

Show songs from:

Add a Source

 

For example, add your Downloads folder

 

Now i can see a music file (an mp3) in my "Local Files"

On my desktop running Debian 'buster' I can play the song.

 

Can you add a source?

Once you add it, can you see any muisc files in your "Local Files?

If you can't play the song from that file, can you play it with another music player?

 

I'm sure that playing local files used to work for me some time in the past without setting that option (or perhaps my settings got reset).

 

But I don't think it was ever possible to play .flac files. You should be able to play .mp3 and .m4a files.

Re: Local Files doesn't work

cHDMmFRE
Casual Listener

This is the solution: https://community.spotify.com/t5/Desktop-Linux/linux-error-Spotify-can-t-play-this-right-now-If-you-...

It should work for Arch-based distros. Should also work for other distros if they can find the same package.

Re: Local Files doesn't work

kraxie
Casual Listener

Seems to work fine, thanks a lot for the help!

(not marking it as a solution, as it's just a workaround)

Highlighted

Re: Local Files doesn't work

cHDMmFRE
Casual Listener

I should ask, what kind of solution do you expect?

SUGGESTED POSTS