Help Wizard

Step 1


Login with spotify 1.0.1 on linux

Login with spotify 1.0.1 on linux



I use facebook to log into spotify, after the 1.0.1 update(haven't tried 1.0.0), I can't login when using facebook, when I click sign in it takes me to a browser where I use the 2 step indentification, when that is done it says that I can close the browser, but the spotify client never gets to know that I have signed in through the browser.


Any sollution for this?

1 Reply


I'm getting the same problem. Tried on Ubuntu 12.04 with Google Chrome and on Ubuntu 15.04 with Firefox - same problem.


Here's what gets dumped to console when I click login:


11:41:56.169 I [session_auth_token_manager.cpp:351] CSRF domain='*' csrf_hash='f88364cdd2c3927f5a92838b0d8c6e4586165de4'

(process:4598): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
11:42:00.140 E [rpc_connection.cpp:1210         ] Socket error 103
11:42:00.145 E [rpc_connection.cpp:1210         ] Socket error 103


Running spotify-client 1:


I tried the 0.9 (stable) build, and it doesn't even start due to dependency errors. It would be nice if I could just decouple my account from Facebook and be done with it, but that seems to be impossible for an end user.


Suggested posts