[Media Key] Media Key not binded with Spotify on CENTOS

Reply

[Media Key] Media Key not binded with Spotify on CENTOS

BenyaminL
Regular

Plan

Premium

Country

Indonesia

Device

Thinkpad X240

Operating System

CentOS 7.6 (Last December 2018) with XFCE Desktop

 

My Question or Issue

My issue is the spotify doesn't follow the key binding of my laptop. I tried to emulate also using xdotools(http://xmodulo.com/simulate-key-press-mouse-movement-linux.html) No hope, I tried to run `xdotool key XF86AudioPlay`, 

 

The expected result is spotify play/pause the song, but the result is it ignores it. Other media player that I tried to use and emulate using xdotool parole, rhythmbox, amarok, pragha and other. 

 

I already remove pragha key binding on XFCE settings (https://forum.xfce.org/viewtopic.php?id=8179), so it's not the problem. 

In the end it's the first time I use spotify on linux, so I need some answer for this, is there any work arround? Thanks.

 

Version 1.1.5.153.gf614956d from snap package on centOS. Thanks !

 

2 Replies

Re: [Media Key] Media Key not binded with Spotify on CENTOS

balaketh
Casual Listener

I don't know if Linux will actually support media key control out of the box, but you could use something like playerctl and set up bindings for that? 

 

See here:

https://github.com/acrisci/playerctl

Re: [Media Key] Media Key not binded with Spotify on CENTOS

BenyaminL
Regular
By default most of distro support it out of the box. Then spotify should support it out of the box.
SUGGESTED POSTS