Media Keys Don't Work


Re: Media Keys Don't Work

Rising Star 11 ArtGravity
Rising Star 11

I found that the suggestion to use mpris-control did exactly what I wanted, and this is no longer problematic for me.

ArtGravityRising Star 11
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Media Keys Don't Work

Media keys stopped working for me after an update and then started working again suddenly. I checked the version and it's 1: I don't know if the client was upgraded or a dependent package was upgraded.

Re: Media Keys Don't Work

Music Fan

EDIT: my bad. reboot fixed it

The latest snap update is not with media keys too on Kubuntu 19.04. It worked with the previous versions (but that couldn't play local files due to a bug). Spotify doesn't show up in the media player widget

Re: Media Keys Don't Work


Spotify . Running on Gentoo with Plasma desktop. All media players and browsers work flawlessly with media keys, not Spotify. Alternate media shortcuts via D-Bus commands is a nasty hack. Please address this.

Re: Media Keys Don't Work

Not working again for me either.  I notice it works for awhile after a
reboot but then I think plasmashell or pulseaudio crashed and had to be
restarted and then the media keys stopped working again.
Do the devs read these? I wonder if the code is relying on stale

Re: Media Keys Don't Work


tnx so much