Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


No internet connection detected (eror code:4) - Ubuntu 20.04

No internet connection detected (eror code:4) - Ubuntu 20.04

Plan Premium


Operating System Ubuntu 20.04


My Question or Issue

I have update to version 1: yesterday and since then spotify tells me there is no internet connection (although the PC has access to internet).
I have tried clear the cache, change proxy settings to No Proxy without sucess.

25 Replies

Weirdest thing is that despite being "offline", I can still login and then it sees and shows which song is being played on another device at the same moment with the same account...

Hi! I faced the same issue. I have changed the dns settings on my router from auto to and it helped

I'm having this same issue on Elementary OS Hera 5.1.7 since I last updated Spotify. After some minutes of running the app, it seems to recover itself.

Hi, I'm also having this issue since I updated Spotify to version on Ubuntu 18.04.


I tried to delete Spotify folder in .cache but the issue happened again after 2 minutes. See my logs in the attachments.


I hope someone at Spotify dev team will have a look to our problem

I finally went for the snap version ( which doesn't show the problem. Changing DNS setting is not an option for me.

I've seen the DNS suggestion several times, but it doesn't work for me. I refuse to use Snap, but still have the issue with the Flatpak.

This is also happening to me.  When using my VPN it happens 100% of the time, when not using it it's inconsistent, sometimes I can listen for an hour or so before I get the error, other times it happens straight away.

The only thing I've found which works for me is to turn off the wifi on my laptop and turn it back on again.


Operating System: Linux Mint 19.3
Kernel: Linux 5.3.0-24-generic
Architecture: x86-64


Spotify version:

Hi all,


I face exactly the same issue. I tried deleting the cache and reinstalling the app, but I saw no improvement.


Operating System: Linux Mint 19.3
Kernel: Linux 5.4.0-52
Architecture: x86-64


Update: The DNS work around fixed the issue. I used to have Open DNS, but now I changed it and the problem is gone, at least for now.

I'm also having this problem. Is the previous version available somewhere until this bug is fixed? Right now my desktop app is completely unusable. -.- I checked apt show, but it's only showing the current version and not the previous one, 1:

It happen to me often recently as well - I have same Spotify version
For me it is connected with connecting to VPN (Cisco AnyConnect)
Restarting resolve deamon helps:
service systemd-resolved restart


Same issue on my side.


OS: Linux Mint 19.3

App version:


I'm cleared my .cache folder, changed my DNS,  restart systemd-resolved



Same here for version on Linux Mint 19.1 . The issue occurs seemingly randomly, sometimes resolving itself after a few minutes, sometimes not. Similarly, messing around with the network connection (re-connecting to WiFi, connecting/disconnecting to VPN) sometimes fixes it, sometimes not.

I updated to version and it's work !
This version look like be available only on snap format 😕

Same issue on Linux Mint 20.

I also tried everything. Arch linux, kde, wireguard. Developers, do something already.

Same here(Debian 10):

georgi@fau:~$ cat /etc/debian_version

georgi@fau:elfo$ spotify --version
Spotify version, Copyright (c) 2020, Spotify Ltd

That's interesting. I've had this issue on only elementaryOS(18.04), Ubuntu 20.04 and 20.10 (and several other editions like KDE Neon).

But I'm currently running openSUSE Tumbleweed with the spotify-easyrpm package (spotify v., it's essentially just the .deb file converted to RPM and then installed) with no issues both with my ISP DNS and Cloudflare's DNS.

Maybe some kind of dependency issue then?  I'm using KDE Neon, which is
based on Ubuntu 20.04.  I looked up the versions of the dependencies for
spotify-client and got the following:

libasound2:    1.2.2-2.1ubuntu2.2
libatk-bridge2.0-0:    2.34.2-0ubuntu2~20.04.1
libatomic1:    10.2.0-5ubuntu1~20.04
libcurl3-gnutls:    7.68.0-1ubuntu2.2
libgbm1:    20.3.0~kisak2~f
libgconf-2-4:    3.2.6-6ubuntu1
libglib2.0-0:    2.64.3-1~ubuntu20.04.1
libgtk2.0-0:    2.24.32-4ubuntu4
libnss3:    2:3.49.1-1ubuntu1.5
libssl1.1:    1.1.1f-1ubuntu2
libxss1:    1:1.2.3-1
libxtst6:    2:1.2.3-1
xdg-utils:    1.1.3-2ubuntu1.20.04.1

I begrudgingly installed the desktop app after getting sick of all the limitations of the web client (which I'd much rather be using if it wasn't so stripped down), and this has been a constant problem for me as well. It sometimes happens at random, but also happens 100% of the time when I hibernate my computer. The only fix is closing and re-launching the application. Whenever Spotify decides it's offline, it's still able to stream songs (because I'm not offline), and Spotify Connect still does its whole thing (because I'm not offline), but I'm artificially locked out of most other functionality. Wireshark confirms that songs are actually being streamed over the internet, not from a local cache, and also shows that the client doesn't make any other attempts to load requested pages when it thinks it's offline, even though it would succeed if it bothered to try.

A simple "check again" button in the "no internet connection detected" message would be a viable workaround for me.

Suggested posts