Announcements

Prevent spotify from playing any radio songs

Solved!
Reply

Re: Prevent spotify from playing any radio songs

Schamess
Newbie

The option to disable autoplay seems to have disappeared from my settings.  Is this just me, or has Spotify removed that option?  If they have, that would be very annoying.

Re: Prevent spotify from playing any radio songs

pmgodin
Regular

Strangely, this solution doesn't stop this behavior on my side.

Re: Prevent spotify from playing any radio songs

Pitters
Newbie
I have my auto play off and I am still gettin radio, is there a known fix for this?

Re: Prevent spotify from playing any radio songs

pmgodin
Regular

Found my problem, it appears the "Auto similar songs" setting is per device and not per account. So you have to disable/enable it on each of your devices.

I was controlling music remotly from one device the another device on wich the "Autoplay" setting was not disabled.

Re: Prevent spotify from playing any radio songs

milanarda
Regular

I have the same problem on iPhone 6. Tried to update Spotify, with no effect. There still is no toggle for autoplay. 

 

It also seems to force autoplay on while listening on other devices. This is really irritating.

Re: Prevent spotify from playing any radio songs

milanarda
Regular

For some unknown reason today the autoplay toggle had returned to my iPhone. This is weird, but I'm glad I got to turn autoplay off. I hope the toggle stays there so I don't have to deal with this again. 

SUGGESTED POSTS