Segmentation fault (core dumped) is back


Re: Segmentation fault (core dumped) is back


so this was the first thing I tried and when i compared versions they were exactly the same, so it was no surprise they both suffered the same issue when the snap version sig faulted on me :/


honestly, it can be nothing else but a race condition... if you slow your machine down or artificially slow down the app with something like cpulimit, the app usually starts up.. it is completely unusable but it didn't seem to sig fault as often.. the fact that we can't consistently repro it within it self points to a race condition.


there is not much we can do but wait for them to patch it in engineering, or wait for them to open high q in the webclient, i already looked for the old version of the app but they seem to have pulled it 

Re: Segmentation fault (core dumped) is back


For the record, for all Ubuntu users, this is the downstream bug report:

Re: Segmentation fault (core dumped) is back

Casual Listener
An excellent workaround that worked fine for me on Ubutu 19.04 was to
install more recent versions of libgnutls and rcu-gnutls from debian.

Just installed

and spotify runs fine. The problem seems to come from gnutls+multithreading.

Re: Segmentation fault (core dumped) is back

Music Fan

did you read the rest of the thread ? ;)

Re: Segmentation fault (core dumped) is back

Casual Listener

the same by me, i cannot run spotify at least 2 weeks...

any advice ?


(SIGSEGV) (core dumped.......

Re: Segmentation fault (core dumped) is back


Yes! treepleks 's tip was definetely on the right track.

Managed my way out of the segmentation faults on Ubuntu 19.04 (disco) x64 by installing the latest eoan libs.
Just go to***** to download the following libs (only amd64 version for most, but both amd64 and i386 for libgnutls30 and libtasn1-6):
libcurl3-gnutls, libgnutls28-dev, libgnutls30 (amd64 and i386), libgnutls-dane0, libgnutls-openssl27, libgnutlsxx28, libtasn1-6 (amd64 and i386), libtasn1-6-dev
Just 'sudo dpkg -i lib*' on the folder you've downloaded those and spotify should load without any SegFaults!

Re: Segmentation fault (core dumped) is back


Here's some commands you can run real quick to fix it (taken from 0x783czar on another thread, but this is the first result on google so I figure I'll add it here to help save people some time):



Also running Pop_OS! here (19.04). Using some of the earlier posts I got it working after doing the following. If the last command doesn't work, run 'apt --fix-broken install' and try the last command again. After doing this it started working for me!

sudo apt install libssh2-1

curl -o ~/Downloads/libgnutls30_3.6.8-2_amd64.deb 

curl -o ~/Downloads/libgnutls30_3.6.8-2_i386.deb 

curl -o ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb

sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb

The reason for this is, as far as I understand it, is that there is a missing patch in the libcurl3-gnutls package in Ubuntu based distributions. However Debian has patched their version of the package. And so installing their version of the package (and its needed dependencies) will get it working."


Re: Segmentation fault (core dumped) is back

Casual Listener

You are the man.


Can confirm that standard Spotify (.deb not snap) now works and starts as intended.


No need to install i386 packages actually.

And the versions from the previous post fails (fix broken install WON'T work) because they are just broken links to the FTP; these are the correct versions that allow apt to continue working properly.


curl -o ~/Downloads/libtasn1-6_4.14-2_amd64.deb

curl -o ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb

curl -o ~/Downloads/libgnutls30_3.6.9-4_amd64.deb

Re: Segmentation fault (core dumped) is back


Thanks grimpressive, Awesome - works!

When downloaded click on each package and install. Reboot.


Re: Segmentation fault (core dumped) is back


That didn't work for me, but it did send me in the right direction.

Apparently those libraries are being upgraded constantly, so two of them are currently giving 404. My bet was to get the immediate following version.

This is wat I did (as root):

cd /tmp
dpkg -i libtasn1-6_4.14-3_amd64.deb
dpkg -i libgnutls30_3.6.9-5_amd64.deb
dpkg -i libcurl3-gnutls_7.64.0-4_amd64.deb

It should work right out of the box, but just in case it might be useful to run aptitude install -f.

(If you don't know what you're doing, don't do that!).



PS: If this happens again to anyone, just follow the links, remove the filename from the URL and look in the list a file with the same name but with newer versions (i.e. bigger numbers in the last part). Don't try to jump to the last available version, just go to the immediate newer version.