Slackware64-current - missing libnettle.so.6

Solved!
Reply

Slackware64-current - missing libnettle.so.6

MikeTatsuo
Casual Listener
  1. Slackware64-current
  2. Free
  3. 1.0.89
  4. Spotify doesn't start, and on the console give me the error 
    /opt/spotify/usr/bin/spotify: error while loading shared libraries: libnettle.so.6: cannot open shared object file: No such file or directory
1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Slackware64-current - missing libnettle.so.6

MikeTatsuo
Casual Listener

UPDATE: I managed to solve the issue, thanks to Giacomo (https://github.com/jak3)

 

The Spotify in the sbopkg for Slackware-current has the file /opt/spotify/usr/lib/libcurl-gnutls.so.4 linked to libcurl-gnutls.so.4.5.0 in the same folder, so Giacomo suggested to create a symlink libcurl-gnutls.so.4 to /usr/lib64/libcurl.so, so I renamed the libcurl-gnutls.so.4 to libcurl-gnutls.so.4.bkp

mv /opt/spotify/usr/lib/libcurl-gnutls.so.4 /opt/spotify/usr/lib/libcurl-gnutls.so.4.bkp

 

and created a symlink to /usr/lib64/libcurl.so

ln -sf /usr/lib64/libcurl.so /opt/spotify/usr/lib/libcurl-gnutls.so.4

 

and worked :-D

6 Replies

Re: Slackware64-current - missing libnettle.so.6

somnophobe
Roadie

The current version of the package is 1:1.1.5.153.gf614956d-16 - have you tried updating?

Re: Slackware64-current - missing libnettle.so.6

gysddn
Visitor

Have you tried installing/updating nettle package?

Just saying...

Solution!

Re: Slackware64-current - missing libnettle.so.6

MikeTatsuo
Casual Listener

UPDATE: I managed to solve the issue, thanks to Giacomo (https://github.com/jak3)

 

The Spotify in the sbopkg for Slackware-current has the file /opt/spotify/usr/lib/libcurl-gnutls.so.4 linked to libcurl-gnutls.so.4.5.0 in the same folder, so Giacomo suggested to create a symlink libcurl-gnutls.so.4 to /usr/lib64/libcurl.so, so I renamed the libcurl-gnutls.so.4 to libcurl-gnutls.so.4.bkp

mv /opt/spotify/usr/lib/libcurl-gnutls.so.4 /opt/spotify/usr/lib/libcurl-gnutls.so.4.bkp

 

and created a symlink to /usr/lib64/libcurl.so

ln -sf /usr/lib64/libcurl.so /opt/spotify/usr/lib/libcurl-gnutls.so.4

 

and worked :-D

Re: Slackware64-current - missing libnettle.so.6

MikeTatsuo
Casual Listener

Reply for somnophobe 

 

Because the Spotify is built for Ubuntu, it has some libraries which don't exist in the Slackware, so the latest version working, installing by sbopkg is what have.

 

Reply for gysddn

 

I already have the latest nettle, the issue is because the Spotify is looking for an old version, and I don't think downgrading is an acceptable solution.

Re: Slackware64-current - missing libnettle.so.6

m_b_tegner
Regular

Slackware64-current uses nettle 3.5.1 (libnettle.so.7.0) so making a symlink to the system /usr/lib64/libcurl.so.4.5.0 seems to work.

Highlighted

Re: Slackware64-current - missing libnettle.so.6

m_b_tegner
Regular

Another option is to rebuild curl without SSL but with GNUTLS. Uncomment/and add the following lines in the curl.Slackbuild-script:

# Uncomment to build a no-SSL version:
SSLOPT=--without-ssl
./configure \
--prefix=/usr \
 --libdir=/usr/lib${LIBDIRSUFFIX} \
 --mandir=/usr/man \
 --with-ca-bundle=/usr/share/curl/ca-bundle.crt \
 --with-libssh2 \
 --with-gnutls \
 --enable-static=no \
 $SSLOPT || exit 1

 

Place the resulting libcurl.so.4.5.0 in your Spotify installation directory. Rename as libcurl-gnutls.so.4 and you are good to go. Keep in mind that you will need to rebuild this every time nettle is upgraded since libcurl is bulit against nettle.

 

 

SUGGESTED POSTS